summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-08-26 00:55:15 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-08-26 01:53:36 +0200
commit50a78638cb0104d382b0fcd34b5e6ab328787ff7 (patch)
tree564c8c78e770e803fc921930aec67d55a667cb67 /sys-fs
parentgames-server/minecraft-server: add 1.21.1, drop 1.21.0 (diff)
downloadgentoo-50a78638cb0104d382b0fcd34b5e6ab328787ff7.tar.gz
gentoo-50a78638cb0104d382b0fcd34b5e6ab328787ff7.tar.bz2
gentoo-50a78638cb0104d382b0fcd34b5e6ab328787ff7.zip
sys-fs/cryptmount: add 6.3.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cryptmount/Manifest1
-rw-r--r--sys-fs/cryptmount/cryptmount-6.3.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/sys-fs/cryptmount/Manifest b/sys-fs/cryptmount/Manifest
index f80e1e8ced04..a0a16a69298c 100644
--- a/sys-fs/cryptmount/Manifest
+++ b/sys-fs/cryptmount/Manifest
@@ -1 +1,2 @@
DIST cryptmount-6.2.0.tar.gz 548497 BLAKE2B 45602d86624464c8c1c2ad9cf3ffc4bf311d60ae16c2294111b1fc98bb0e02952c69c767a1c583428c3d8eb0ade2caddb17d3187f4dd34d780772b299ea1a6c0 SHA512 005d9333792a567515ce6d487d2dfa18f19cb077a64d9c356562acefc1947581d2d0f584ad623e0aab8aed1b34f1614af3a42f0c582d31e0831cdb8eb22bb7ce
+DIST cryptmount-6.3.0.tar.gz 373196 BLAKE2B b59127f9944f4bf267d4272bc026909b704f474b2fd2a20baf9125f9b32b33ecfd5523c6ef05098e6467e9b7e938daba55685dc47a3317a4913aef4c517f66f2 SHA512 15f19a1ff7409b35be2cde3d791c8d476c98ffcaf3dd9217076703b0e0baafe999a0608a88cc51039ba2e9c26cb297261128a5efeacd1a6397c5d3300886ac4d
diff --git a/sys-fs/cryptmount/cryptmount-6.3.0.ebuild b/sys-fs/cryptmount/cryptmount-6.3.0.ebuild
new file mode 100644
index 000000000000..b03b2950fe73
--- /dev/null
+++ b/sys-fs/cryptmount/cryptmount-6.3.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info
+
+DESCRIPTION="A utility for management and user-mode mounting of encrypted filesystems"
+HOMEPAGE="http://cryptmount.sourceforge.net/"
+SRC_URI="https://github.com/rwpenney/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="argv0switch cswap fsck +gcrypt +largefile mount +nls +luks +openssl systemd"
+REQUIRED_USE="
+ luks? ( gcrypt )
+ openssl? ( gcrypt )
+"
+
+RDEPEND="
+ sys-fs/lvm2
+ virtual/libiconv
+ virtual/libintl
+ gcrypt? ( dev-libs/libgcrypt:0= )
+ luks? ( sys-fs/cryptsetup )
+ openssl? ( dev-libs/openssl:0= )
+ systemd? ( sys-apps/systemd )
+"
+
+DEPEND="
+ ${RDEPEND}
+ sys-kernel/linux-headers
+"
+
+BDEPEND="nls? ( sys-devel/gettext )"
+
+CONFIG_CHECK="BLK_DEV_DM"
+ERROR_BLK_DEV_DM="
+ Please enable Device Mapper support in your kernel config
+ -> Device Drivers
+ -> Multiple devices driver support (RAID and LVM)
+ -> Multiple devices driver support (RAID and LVM)
+ <*>/<M> Device mapper support
+"
+
+src_prepare() {
+ default
+
+ # Fix doc directory
+ sed -e 's/doc\/cryptmount/doc\/${PF}/g' -i Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconf=(
+ --disable-rpath
+ $(use_enable argv0switch)
+ $(use_enable cswap)
+ $(use_enable fsck)
+ $(use_with gcrypt libgcrypt)
+ $(use_enable largefile)
+ $(use_enable mount delegation)
+ $(use_enable nls)
+ $(use_enable luks)
+ $(use_enable openssl openssl-compat)
+ $(use_with systemd)
+ )
+
+ econf "${myeconf[@]}"
+}