summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2022-10-23 19:01:20 -0400
committerMike Pagano <mpagano@gentoo.org>2022-10-23 19:01:20 -0400
commitb70c6de273dda7d10368cd7d03beece11574956a (patch)
tree9f84e6a58bca7e166ef0c9e9e0a701aac54d2589 /sys-kernel/git-sources
parentgames-arcade/rocksndiamonds: fix deps (diff)
downloadgentoo-b70c6de273dda7d10368cd7d03beece11574956a.tar.gz
gentoo-b70c6de273dda7d10368cd7d03beece11574956a.tar.bz2
gentoo-b70c6de273dda7d10368cd7d03beece11574956a.zip
sys-kernel/git-sources: add 6.1_rc2
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.1_rc2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 59b7243e339a..0736a16dc55d 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -1,2 +1,3 @@
DIST linux-6.0.tar.xz 133886176 BLAKE2B c09a9c877ac0fac83dc31d2d04d96f0a3331d4ed78e3ad4edfd4dc077e1c11d0c49f419fdac4008b5c93d1b09c2b724e12ef0b38371ad0962908abf85dfa95fa SHA512 bac41a7aeb6e809616cee2f13dcd1c45e829dfd1ccf60aee1dc4c46b1e28532f4485c7d819a32940de84fdfbf89db80a4e919bce8a74b2948c5a01551771b714
DIST patch-6.1-rc1.patch 50406846 BLAKE2B 357a8a4fab087a67f79efcab4ada2a5d65e77c5ef13a7ab9d58963de31adeb0b3b841b7120acd6bba1767ef2080f086eec2d72ce98a6c21d1920478d6b9fb244 SHA512 80f3fff420e06ea937274ef5ea8927d57f633b0bb1f702ef2b583bd9eddae4c65b0587f57144d1d9eec0aee815d5676d9fc9187779a6149f6c916c432c5a8ea3
+DIST patch-6.1-rc2.patch 51039243 BLAKE2B 0f0727885c52a12e5eaf907d40752705a2dc8b174e7ce8f2fd97a1521396db2b32069acc323e732749839e4645dc550be1db16afc942a9513d437160cf509e15 SHA512 753ab27541248489bc3280595b22e138c063defec1ac4f3c7ee60cd9212345e94061ab6206f1cb1c712d76220db0b41b8197ea35e4c72851705046ca986dbb0a
diff --git a/sys-kernel/git-sources/git-sources-6.1_rc2.ebuild b/sys-kernel/git-sources/git-sources-6.1_rc2.ebuild
new file mode 100644
index 000000000000..b91652186526
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.1_rc2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="6.0"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}