summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-01-23 11:11:25 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-01-23 11:13:44 +0200
commit3f8ccda939720fd542e1c393d0819ee05a52f537 (patch)
tree8fba435754dfcfce7b9e3d9ecaf151c83fc2f95b /sys-kernel/pf-sources
parentsci-astronomy/celestia: Fix missing dependency (diff)
downloadgentoo-3f8ccda939720fd542e1c393d0819ee05a52f537.tar.gz
gentoo-3f8ccda939720fd542e1c393d0819ee05a52f537.tar.bz2
gentoo-3f8ccda939720fd542e1c393d0819ee05a52f537.zip
sys-kernel/pf-sources: add 5.15.{14..16} patches for CAP_SYS_ADMIN
Bug: https://bugs.gentoo.org/831606 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-kernel/pf-sources')
-rw-r--r--sys-kernel/pf-sources/Manifest3
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.15_p6-r1.ebuild82
2 files changed, 85 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index dfe4cddf54fe..74ff89b7795c 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -1,3 +1,6 @@
+DIST 1013_linux-5.15.14-pf.patch 99091 BLAKE2B eb5083f51326ac117160edc94494a438b2df252b777e21b5e2cf5f5e1cdf1e689a6f44c95ce724a9dbd414880a564e9c11b5fd97041b8d7600b65c18cd4fa8d8 SHA512 c87d54f7572c178c5c498afd4acc1ddd11c67caed76f2931a4a3c113ca434e369dda4aacbbc8f6ba04a7b3dec5cf732e0b19f3937c4638463feba3fecfca1363
+DIST 1014_linux-5.15.15-pf.patch 39365 BLAKE2B 3a0554c57804194364ca2565e4766cc3c3ddddac16b8e4e155caece2f5168e420547c3e49ef4246fdf799685ef2989549b05725f56a0bb3a6a9d40b49030731d SHA512 dce4c8f7a4da949dbd49a6aefd018404cc274ead04eda4cb8c9a74416c32a42bfd6cd76dfb29a89637ebac1186f0558ea1f6e1da3c197300f94791c5a0412890
+DIST 1015_linux-5.15.16-pf.patch 42879 BLAKE2B be5248dc26b5aa46459d97151fa8d017a6ef21375fc412373fb9691118fa9c299e5af76d9c527b2a7341077d3f460728f27b91d2ae8799049185901617a7de64 SHA512 65319bd62c26956fafc2ea4c08454b3ad169bafecb9c0a894b24ef5b77255f2dd01d0a5426436ab779e4e5c00fa1f123fb07abd6a074242dfad0d06906e140b5
DIST 1510_fs-enable-link-security-restrictions-by-default-5.12.patch 810 BLAKE2B bb749b365f37988253206ddff130651e1042af49a6c773ba6f93642d5927af9a9926eab278979e048c13d2ca683e726a5d0cd509de9e6177d59c85197051e230 SHA512 c97a3799a2d5e4da9c9dfe129756da629fba8183479b02ca82f9b6d9993f17a165a96bd35ac50eb25fb293785b9b529a95165b1a2eb79c05134bee8ccf22a5d3
DIST 5020_BMQ-and-PDS-io-scheduler-v5.12-r1.patch 267548 BLAKE2B 77a1646ffbc67ed88af564b73cf63f0374772bdc1075e771a93ee4fe257b94cb3766a4842898b48f4343458d0b507229182220c7daeb5532df610b964c6640e7 SHA512 3500160e35ffb16771f9ae556f0c8260e616833898f05b3c03e6197b47b20fe3a25f717117ca8257852734c1764e407fbfe70aac077c482e9f9fca97cdd938ee
DIST 5021_BMQ-and-PDS-gentoo-defaults-5.14.patch 348 BLAKE2B 50ac91380b7221aa30ead9e842f038117b0f4ef4b6538b8f083a9f4467db23ab2f74643e65197dd9201da9b6cde17b192ed09e7d544ad095391c2cde6d9f2b8f SHA512 166a73397b133e20b92c37b72ae1edfe4cce017293b978b523980e28526950dfedf1081252191ff95462896a16ee790dadf55cda2edc49452b960079d89a6a9b
diff --git a/sys-kernel/pf-sources/pf-sources-5.15_p6-r1.ebuild b/sys-kernel/pf-sources/pf-sources-5.15_p6-r1.ebuild
new file mode 100644
index 000000000000..6006c03de562
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.15_p6-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Define what default functions to run
+ETYPE="sources"
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# Just get basic genpatches, -pf patch set already includes vanilla-linux updates
+K_GENPATCHES_VER="2"
+
+# -pf already sets EXTRAVERSION to kernel Makefile
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security team
+K_SECURITY_UNSUPPORTED="1"
+
+# We want the very basic patches from gentoo-sources, experimental patch is
+# already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+# major kernel version, e.g. 5.14
+SHPV="${PV/_p*/}"
+
+# https://gitlab.com/alfredchen/projectc/ revision for a major version,
+# e.g. prjc-v5.14-r2 = 2
+PRJC_R=1
+
+inherit kernel-2 optfeature
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/-/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+SRC_URI="${KERNEL_URI}
+ https://github.com/pfactum/pf-kernel/compare/v${SHPV}...v${SHPV}-pf${PV/*_p/}.diff -> ${P}.patch
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${SHPV}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${SHPV}-${K_GENPATCHES_VER}.extras.tar.xz
+ https://gitlab.com/alfredchen/projectc/-/raw/master/${SHPV}/prjc_v${SHPV}-r${PRJC_R}.patch
+ https://dev.gentoo.org/~mpagano/genpatches/trunk/${SHPV}/5021_BMQ-and-PDS-gentoo-defaults.patch -> 5021_BMQ-and-PDS-gentoo-defaults-${SHPV}.patch
+ https://dev.gentoo.org/~juippis/patches/pf-sources-5.16-pf6/1013_linux-5.15.14-pf.patch
+ https://dev.gentoo.org/~juippis/patches/pf-sources-5.16-pf6/1014_linux-5.15.15-pf.patch
+ https://dev.gentoo.org/~juippis/patches/pf-sources-5.16-pf6/1015_linux-5.15.16-pf.patch"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/linux-${PV}-pf-${PR}"
+
+PATCHES=( "${DISTDIR}/${P}.patch"
+ "${DISTDIR}/prjc_v${SHPV}-r${PRJC_R}.patch"
+ "${DISTDIR}/5021_BMQ-and-PDS-gentoo-defaults-${SHPV}.patch"
+ "${DISTDIR}/1013_linux-5.15.14-pf.patch"
+ "${DISTDIR}/1014_linux-5.15.15-pf.patch"
+ "${DISTDIR}/1015_linux-5.15.16-pf.patch" )
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+ see: ${HOMEPAGE}."
+
+pkg_setup() {
+ ewarn ""
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn ""
+
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ # kernel-2_src_prepare doesn't apply PATCHES().
+ default
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ optfeature "userspace KSM helper" sys-process/uksmd
+}