summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2024-07-07 18:38:56 -0400
committerMike Pagano <mpagano@gentoo.org>2024-07-07 18:38:56 -0400
commit33e8622f8ef9bacae696a6535f5fb9fd5ad2d02b (patch)
tree6d2ac28c01154f0f72d027fa1f0510e6907da98a /sys-kernel
parentkde-apps/kpimtextedit: Re-add accidentally removed IUSE designer metadata (diff)
downloadgentoo-33e8622f8ef9bacae696a6535f5fb9fd5ad2d02b.tar.gz
gentoo-33e8622f8ef9bacae696a6535f5fb9fd5ad2d02b.tar.bz2
gentoo-33e8622f8ef9bacae696a6535f5fb9fd5ad2d02b.zip
sys-kernel/git-sources: add 6.10_rc7
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.10_rc7.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index d5b787f3804c..42e1d17ee75a 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -5,3 +5,4 @@ DIST patch-6.10-rc3.patch 41282995 BLAKE2B b507c62020cb25bc3d7d7408222e018290c91
DIST patch-6.10-rc4.patch 41531928 BLAKE2B a3945dbfd08a30ec82f8aeca668b2122be4d606ecc6d1a810bbc39d1eb0b69bedc9731cb98066eb8fd26447a8e6c57f7d523acdbed1f2a35be4a105f879c9f42 SHA512 efc88b09fe7cd5d54662a53aa94e9a6eb479f3e8de259903c8a4f7c9073cc9ef5dc16c2cc36c85296e35fca34758a93ceabcfe0600363c1a8b5383af8633ff55
DIST patch-6.10-rc5.patch 41852953 BLAKE2B cd1faa6d5e035eb135fddba971c7885c2e290a2369b8f82a74eda23aa7ee80ee0e3f62d9fa3b0105b9baf1f9da719be63756f6e29a49c9a07c6076608ba4b739 SHA512 3d9a0ee7c45172338692f111b3d5022d46eb26d2a9451f0a3fe730648cc4b3f0871dcebfa9b69670fe973eefb6beb15844e6476d264b35c9ea0e22641f364810
DIST patch-6.10-rc6.patch 42201969 BLAKE2B 3d4e681c69432c9fe0e274732425ee4e5b01547fa15d9820c6ccc892b9686212117bf24614cf0f66b4f5f2cbed750a3d601a09d2e2bad8b69c3d191b1e0166b8 SHA512 e5b2eca573c6b24db12d791da30fce61441f25db91288e008d627d41c4827258fa83db2c5171c8aa30af2a020d6e06e2f0590fa93fb8360fdfd2c92e3775f646
+DIST patch-6.10-rc7.patch 42371387 BLAKE2B fea07afbe9da8c9239094e91a5650b4d956b6e9c19f04d01332b1abd17690d4fba9379683dc5a00ff53ce7bcb533e794ca66fd00f9ed3fd351465e447657590e SHA512 af4792d94d01d1b41f749741d93c5a51586b7ff5a1b2dbc8f183e6b8125394c17fb2ac6c725f661f37af7070223fae235fde685b46de14ddf4f5537eeda74d9e
diff --git a/sys-kernel/git-sources/git-sources-6.10_rc7.ebuild b/sys-kernel/git-sources/git-sources-6.10_rc7.ebuild
new file mode 100644
index 000000000000..edb1a477e11c
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.10_rc7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="6.9"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}