summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2019-09-08 18:41:27 -0400
committerMike Pagano <mpagano@gentoo.org>2019-09-08 18:41:36 -0400
commit9d57c98453f25e773c1824cfe2a3196bb7e7495f (patch)
tree02e91310da7ddd5acfbe684c0c2317377d73bff8 /sys-kernel
parentnet-libs/rpcsvc-proto: arm64 stable (bug #693310) (diff)
downloadgentoo-9d57c98453f25e773c1824cfe2a3196bb7e7495f.tar.gz
gentoo-9d57c98453f25e773c1824cfe2a3196bb7e7495f.tar.bz2
gentoo-9d57c98453f25e773c1824cfe2a3196bb7e7495f.zip
sys-kernel/git-sources: Linux patch 5.3-rc8
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.3_rc8.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index a5bd534bf530..11621b6cefc0 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -6,3 +6,4 @@ DIST patch-5.3-rc4.patch 94800817 BLAKE2B 3998bbc5c0147cb759920052e60b391e53cf73
DIST patch-5.3-rc5.patch 94949483 BLAKE2B 656d9c20de02f6203ba1d5b011f6cbfdca8a953905880287e1d645da1cb5851fd7422c7f9ed00c6487b03b578fa1ef08f9745771b8436ce06710a54e7e2375e9 SHA512 2736a8228ecda89948ac4df91eb3b930f76da442ae14ff72155048d9db048d7a4a0b3b25a5f83f06cd8d1b87abdd82cce5f3e6d5c575db6d9df72a029c7c3b3b
DIST patch-5.3-rc6.patch 95212932 BLAKE2B 22bda01b2cb8eff5b57e757c2b53c9be3db5f82458794988449ff45b6ba44f2e9d867f8e214c80ebaa54101caa0ca5a4a96bf1936d84ba8c0e4ebe51b103780f SHA512 47f212970ab571609bc5f51cbd0207be7baa0c5fa9ba47eb348613fbbdaa3f8031f57624e6b05d5873594c82f811eaec4608de44e8ee5ce5df53112f3b192df0
DIST patch-5.3-rc7.patch 95534361 BLAKE2B 427dd100e4ff4557316c92bae3d59ecd43ea9c37bbbda92fd3c36d106587f5494b9339e2dfd436479d0c43fa13d98aeb17ee62b01fd0c3fdddc3195e24af41ca SHA512 6004b20248c340f7c35d254787e156f5ac6ec072a4a4fea96f6feed76c8f9b5f0cb3f1037c2940288898d8778ec503ed847f8df7e2801db884186e8f624b1835
+DIST patch-5.3-rc8.patch 95585085 BLAKE2B 3b754461e9de91e5ca44172dbfda6e85ef3bd3eff695af46acb9bb6594eca227f1a0dce8a5519d4d2a15fbba237d3548cdacfeb0d4c591869b97377a2beced0f SHA512 470cd87fa770aac56675e2a2f088ee67d38b9efa7a6f2bc1d751774ae5951790ce93aa94c709d68f9e25f2eef8aa2e9f5d0c5666055f196a09e177b746388dbb
diff --git a/sys-kernel/git-sources/git-sources-5.3_rc8.ebuild b/sys-kernel/git-sources/git-sources-5.3_rc8.ebuild
new file mode 100644
index 000000000000..71a45a3201b9
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.3_rc8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.2"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}