summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2023-05-07 23:30:39 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2023-05-07 23:31:04 +0200
commita24dfdd4b518e5d196337ffd03ce2ab8f304591d (patch)
tree2f91066a55beb0fd83d7799c768d7bb607c072f3 /sys-libs/glibc/glibc-9999.ebuild
parentapp-editors/bluefish: Drop old versions (diff)
downloadgentoo-a24dfdd4b518e5d196337ffd03ce2ab8f304591d.tar.gz
gentoo-a24dfdd4b518e5d196337ffd03ce2ab8f304591d.tar.bz2
gentoo-a24dfdd4b518e5d196337ffd03ce2ab8f304591d.zip
sys-libs/glibc: Fix parallelization during binpkg install
Bug: https://bugs.gentoo.org/736794 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-libs/glibc/glibc-9999.ebuild')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index f16a004cdc94..cc98168d7f92 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -1271,7 +1271,15 @@ run_locale_gen() {
locale_list="${root%/}/usr/share/i18n/SUPPORTED"
fi
- set -- locale-gen ${inplace} --jobs $(makeopts_jobs) --config "${locale_list}" \
+ # bug 736794: we need to be careful with the parallelization... the number of
+ # processors saved in the environment of a binary package may differ strongly
+ # from the number of processes available during postinst
+ local mygenjobs="$(makeopts_jobs)"
+ if [[ "${EMERGE_FROM}" == "binary" ]] ; then
+ mygenjobs="$(nproc)"
+ fi
+
+ set -- locale-gen ${inplace} --jobs "${mygenjobs}" --config "${locale_list}" \
--destdir "${root}"
echo "$@"
"$@"