summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-05-12 20:39:26 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-05-12 20:44:09 +0200
commitde893769146655fc76b842d21b3cba7cbf4059e3 (patch)
treeb20857ee26b17553f840f9a9755b6a61d9874d67 /sys-libs/libblockdev/libblockdev-2.23-r1.ebuild
parentapp-antivirus/clamav: version bump (diff)
downloadgentoo-de893769146655fc76b842d21b3cba7cbf4059e3.tar.gz
gentoo-de893769146655fc76b842d21b3cba7cbf4059e3.tar.bz2
gentoo-de893769146655fc76b842d21b3cba7cbf4059e3.zip
sys-libs/libblockdev: Don't use bashisms in configure script
Closes: https://bugs.gentoo.org/719442 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs/libblockdev/libblockdev-2.23-r1.ebuild')
-rw-r--r--sys-libs/libblockdev/libblockdev-2.23-r1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-libs/libblockdev/libblockdev-2.23-r1.ebuild b/sys-libs/libblockdev/libblockdev-2.23-r1.ebuild
index c252b7d2104f..105df4812baa 100644
--- a/sys-libs/libblockdev/libblockdev-2.23-r1.ebuild
+++ b/sys-libs/libblockdev/libblockdev-2.23-r1.ebuild
@@ -4,12 +4,12 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-single-r1 xdg-utils
+inherit autotools python-single-r1 xdg-utils
DESCRIPTION="A library for manipulating block devices"
HOMEPAGE="https://github.com/storaged-project/libblockdev"
if [[ "${PV}" == *9999 ]] ; then
- inherit autotools git-r3
+ inherit git-r3
EGIT_REPO_URI="https://github.com/storaged-project/libblockdev.git"
BDEPEND="
sys-devel/autoconf-archive
@@ -66,6 +66,8 @@ BDEPEND+="
REQUIRED_USE="${PYTHON_REQUIRED_USE}
escrow? ( cryptsetup )"
+PATCHES=( "${FILESDIR}/${P}-avoid_bashisms.patch" ) #719442
+
pkg_setup() {
python-single-r1_pkg_setup
}
@@ -73,7 +75,7 @@ pkg_setup() {
src_prepare() {
xdg_environment_reset #623992
default
- [[ "${PV}" == *9999 ]] && eautoreconf
+ eautoreconf
}
src_configure() {