summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-07-22 13:49:49 +0000
committerJoonas Niilola <juippis@gentoo.org>2023-08-11 10:31:56 +0300
commit1c024d17c1e263c246480258749601368b06d1c2 (patch)
tree46a1c85bfd37bde37d66d9fdaaebd6b64a1ca278 /sys-libs/libchipcard
parentapp-office/homebank: add 5.6.5 (diff)
downloadgentoo-1c024d17c1e263c246480258749601368b06d1c2.tar.gz
gentoo-1c024d17c1e263c246480258749601368b06d1c2.tar.bz2
gentoo-1c024d17c1e263c246480258749601368b06d1c2.zip
sys-libs/libchipcard: Fix invalid suffix on literal
Closes: https://bugs.gentoo.org/742428 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31999 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-libs/libchipcard')
-rw-r--r--sys-libs/libchipcard/files/libchipcard-5.1.6-clang16-build-fix.patch12
-rw-r--r--sys-libs/libchipcard/libchipcard-5.1.6-r1.ebuild53
2 files changed, 65 insertions, 0 deletions
diff --git a/sys-libs/libchipcard/files/libchipcard-5.1.6-clang16-build-fix.patch b/sys-libs/libchipcard/files/libchipcard-5.1.6-clang16-build-fix.patch
new file mode 100644
index 000000000000..45f44665beba
--- /dev/null
+++ b/sys-libs/libchipcard/files/libchipcard-5.1.6-clang16-build-fix.patch
@@ -0,0 +1,12 @@
+Bug: https://bugs.gentoo.org/742428
+--- a/src/tools/cardcommander/cardcommander.cpp
++++ b/src/tools/cardcommander/cardcommander.cpp
+@@ -45,7 +45,7 @@
+ using namespace std;
+
+ #define k_PRG_VERSION_INFO \
+- "cardcommander v0.4 (part of libchipcard v"k_CHIPCARD_VERSION_STRING")\n"\
++ "cardcommander v0.4 (part of libchipcard v" k_CHIPCARD_VERSION_STRING ")\n"\
+ "(c) 2006 Martin Preuss<martin@libchipcard.de>\n" \
+ "This program is free software licensed under GPL.\n"\
+ "See COPYING for details.\n"
diff --git a/sys-libs/libchipcard/libchipcard-5.1.6-r1.ebuild b/sys-libs/libchipcard/libchipcard-5.1.6-r1.ebuild
new file mode 100644
index 000000000000..9d507f69d0a4
--- /dev/null
+++ b/sys-libs/libchipcard/libchipcard-5.1.6-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Library for accessing chip cards via chip card readers (terminals)"
+HOMEPAGE="https://www.aquamaniac.de/rdm/projects/libchipcard"
+SRC_URI="https://www.aquamaniac.de/rdm/attachments/download/382/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc examples"
+
+BDEPEND="
+ sys-devel/gettext
+ doc? ( app-doc/doxygen )
+"
+DEPEND="
+ >=sys-apps/pcsc-lite-1.6.2
+ >=sys-libs/gwenhywfar-4.99.22_rc6:=
+ sys-libs/zlib
+ virtual/libintl
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO doc/{CERTIFICATES,CONFIG,IPCCOMMANDS} )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-clang16-build-fix.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ --with-docpath=/usr/share/doc/"${PF}"/apidoc
+ $(use_enable doc full-doc)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ einstalldocs
+
+ if use examples; then
+ docinto tutorials
+ dodoc tutorials/*.{c,h,xml} tutorials/README
+ fi
+
+ find "${D}" -name '*.la' -type f -delete || die
+}