summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-09-14 16:54:39 +0200
committerMichał Górny <mgorny@gentoo.org>2016-09-23 09:29:03 +0200
commit2a34c2f32827c6765fadfdeac3ddce94e97a5350 (patch)
treebf4f20e4fc005df56f9c1cc589f44afa97ccc032 /sys-libs/libomp
parentsys-libs/libomp: Add the LLVM project as co-maintainer (diff)
downloadgentoo-2a34c2f32827c6765fadfdeac3ddce94e97a5350.tar.gz
gentoo-2a34c2f32827c6765fadfdeac3ddce94e97a5350.tar.bz2
gentoo-2a34c2f32827c6765fadfdeac3ddce94e97a5350.zip
sys-libs/libomp: Add a live ebuild
Diffstat (limited to 'sys-libs/libomp')
-rw-r--r--sys-libs/libomp/libomp-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-libs/libomp/libomp-9999.ebuild b/sys-libs/libomp/libomp-9999.ebuild
new file mode 100644
index 000000000000..fe4be82cbfc3
--- /dev/null
+++ b/sys-libs/libomp/libomp-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+
+inherit cmake-multilib git-r3
+
+DESCRIPTION="OpenMP runtime library for LLVM/clang compiler"
+HOMEPAGE="http://openmp.llvm.org"
+SRC_URI=""
+EGIT_REPO_URI="http://llvm.org/git/openmp.git
+ https://github.com/llvm-mirror/openmp.git"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-lang/perl"
+
+multilib_src_configure() {
+ local libdir="$(get_libdir)"
+ local mycmakeargs=(
+ -DLIBOMP_LIBDIR_SUFFIX="${libdir#lib}"
+ # do not install libgomp.so & libiomp5.so aliases
+ -DLIBOMP_INSTALL_ALIASES=OFF
+ )
+ cmake-utils_src_configure
+}