summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <michal.privoznik@gmail.com>2023-11-28 09:53:00 +0100
committerSam James <sam@gentoo.org>2023-12-03 06:22:13 +0000
commit14aefc3644d467b43a76bf4f5f9d3ea23f2ade45 (patch)
tree079250b4b1e96063e6916d04b90d8f60da087a95 /sys-libs/libosinfo
parentsys-apps/osinfo-db-tools: Fix build with >=dev-libs/libxml2-2.12.0 (diff)
downloadgentoo-14aefc3644d467b43a76bf4f5f9d3ea23f2ade45.tar.gz
gentoo-14aefc3644d467b43a76bf4f5f9d3ea23f2ade45.tar.bz2
gentoo-14aefc3644d467b43a76bf4f5f9d3ea23f2ade45.zip
sys-libs/libosinfo: Fix build with >=dev-libs/libxml2-2.12.0
As of its 2.12.0 release, libxml2 cleaned up header files which rendered libosinfo unable to compile. Backport the fix from upstream repo. Signed-off-by: Michal Privoznik <michal.privoznik@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/libosinfo')
-rw-r--r--sys-libs/libosinfo/files/1.11.0-osinfo-Make-xmlError-struct-constant-in-propagate_li.patch32
-rw-r--r--sys-libs/libosinfo/libosinfo-1.10.0-r1.ebuild1
2 files changed, 33 insertions, 0 deletions
diff --git a/sys-libs/libosinfo/files/1.11.0-osinfo-Make-xmlError-struct-constant-in-propagate_li.patch b/sys-libs/libosinfo/files/1.11.0-osinfo-Make-xmlError-struct-constant-in-propagate_li.patch
new file mode 100644
index 000000000000..ea05c46a03b0
--- /dev/null
+++ b/sys-libs/libosinfo/files/1.11.0-osinfo-Make-xmlError-struct-constant-in-propagate_li.patch
@@ -0,0 +1,32 @@
+From 5bbdd06503456784c5ffa22409e8bab50470d673 Mon Sep 17 00:00:00 2001
+Message-ID: <5bbdd06503456784c5ffa22409e8bab50470d673.1701161424.git.mprivozn@redhat.com>
+From: Michal Privoznik <mprivozn@redhat.com>
+Date: Mon, 27 Nov 2023 15:11:45 +0100
+Subject: [PATCH] osinfo: Make xmlError struct constant in
+ propagate_libxml_error()
+
+In libxml2 commit v2.12.0~14 the API changed so that
+xmlGetLastError() returns pointer to a constant xmlError struct.
+Reflect this change in our code.
+
+Signed-off-by: Michal Privoznik <mprivozn@redhat.com>
+---
+ osinfo/osinfo_install_script.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/osinfo/osinfo_install_script.c b/osinfo/osinfo_install_script.c
+index 5800f37..303245a 100644
+--- a/osinfo/osinfo_install_script.c
++++ b/osinfo/osinfo_install_script.c
+@@ -769,7 +769,7 @@ static void propagate_libxml_error(GError **error, const char *format, ...) G_GN
+
+ static void propagate_libxml_error(GError **error, const char *format, ...)
+ {
+- xmlErrorPtr err = xmlGetLastError();
++ const xmlError *err = xmlGetLastError();
+ char *prefix;
+ va_list ap;
+
+--
+2.41.0
+
diff --git a/sys-libs/libosinfo/libosinfo-1.10.0-r1.ebuild b/sys-libs/libosinfo/libosinfo-1.10.0-r1.ebuild
index 4fa2dfb2d4b2..cd1d05bea494 100644
--- a/sys-libs/libosinfo/libosinfo-1.10.0-r1.ebuild
+++ b/sys-libs/libosinfo/libosinfo-1.10.0-r1.ebuild
@@ -45,6 +45,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PV}-build-Add-option-to-disable-libsoup3.patch
+ "${FILESDIR}"/1.11.0-osinfo-Make-xmlError-struct-constant-in-propagate_li.patch
)
src_prepare() {