summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2017-01-20 12:13:09 -0600
committerMike Frysinger <vapier@gentoo.org>2017-01-20 12:13:16 -0600
commit4f015364e4d818e24e584c3685601d75e886a65d (patch)
treee95d9e756af2bb857af5ac41fc16a1f3cb0fcc93 /sys-libs/ncurses
parentx11-libs/libICE: Require libbsd unconditionally. (diff)
downloadgentoo-4f015364e4d818e24e584c3685601d75e886a65d.tar.gz
gentoo-4f015364e4d818e24e584c3685601d75e886a65d.tar.bz2
gentoo-4f015364e4d818e24e584c3685601d75e886a65d.zip
sys-libs/ncurses: fix cross-compiling configure tests #601426
Diffstat (limited to 'sys-libs/ncurses')
-rw-r--r--sys-libs/ncurses/files/ncurses-6.0-cppflags-cross.patch35
-rw-r--r--sys-libs/ncurses/ncurses-6.0-r1.ebuild1
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-libs/ncurses/files/ncurses-6.0-cppflags-cross.patch b/sys-libs/ncurses/files/ncurses-6.0-cppflags-cross.patch
new file mode 100644
index 000000000000..decdc2677904
--- /dev/null
+++ b/sys-libs/ncurses/files/ncurses-6.0-cppflags-cross.patch
@@ -0,0 +1,35 @@
+https://bugs.gentoo.org/601426
+https://lists.gnu.org/archive/html/bug-ncurses/2015-02/msg00012.html
+
+From: John Vogel
+Subject: [PATCH] c++ binding missed when cross compiling
+Date: Mon, 16 Feb 2015 01:01:48 -0500
+
+The configure script hard codes the include dir to the prefix'ed include dir,
+when checking if c++ compiler works. This breaks the compiler's built-in search
+path. I've included two patches. The first works on the configure.in file, which
+requires your autoconf stuff to test and I'm not ready to meddle with at the
+moment. The other works directly on the configure file. I've tested the second
+one; it should mirror what the first patch tries to achieve and works for me.
+
+--- a/configure
++++ b/configure
+@@ -2938,10 +2938,6 @@
+ echo "$as_me:2938: checking if $CXX works" >&5
+ echo $ECHO_N "checking if $CXX works... $ECHO_C" >&6
+
+- save_CPPFLAGS="$CPPFLAGS"
+- eval cf_includedir=${includedir}
+- CPPFLAGS="$CPPFLAGS -I${cf_includedir}"
+-
+ cat >conftest.$ac_ext <<_ACEOF
+ #line 2946 "configure"
+ #include "confdefs.h"
+@@ -2978,7 +2974,6 @@
+ cf_cxx_works=no
+ fi
+ rm -f conftest.$ac_objext conftest.$ac_ext
+- CPPFLAGS="$save_CPPFLAGS"
+
+ echo "$as_me:2983: result: $cf_cxx_works" >&5
+ echo "${ECHO_T}$cf_cxx_works" >&6
diff --git a/sys-libs/ncurses/ncurses-6.0-r1.ebuild b/sys-libs/ncurses/ncurses-6.0-r1.ebuild
index ccdd8a564470..e1735928d7f2 100644
--- a/sys-libs/ncurses/ncurses-6.0-r1.ebuild
+++ b/sys-libs/ncurses/ncurses-6.0-r1.ebuild
@@ -37,6 +37,7 @@ PATCHES=(
"${FILESDIR}/${PN}-6.0-pkg-config.patch"
"${FILESDIR}/${PN}-5.9-gcc-5.patch" #545114
"${FILESDIR}/${PN}-6.0-ticlib.patch" #557360
+ "${FILESDIR}/${PN}-6.0-cppflags-cross.patch" #601426
)
src_prepare() {