summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2021-09-20 09:44:51 -0700
committerPatrick McLean <chutzpah@gentoo.org>2021-09-20 09:46:21 -0700
commite1dfa50ec3b3dfa5d4c3788ab25f545e9b169e24 (patch)
tree43a64d8fbf28616069fde2ab42eeee81829ea0e1 /sys-process/bpytop/bpytop-1.0.67.ebuild
parentdev-lang/python: Remove old (diff)
downloadgentoo-e1dfa50ec3b3dfa5d4c3788ab25f545e9b169e24.tar.gz
gentoo-e1dfa50ec3b3dfa5d4c3788ab25f545e9b169e24.tar.bz2
gentoo-e1dfa50ec3b3dfa5d4c3788ab25f545e9b169e24.zip
sys-process/bpytop-1.0.67: Version bump
Closes: https://bugs.gentoo.org/795468 Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-process/bpytop/bpytop-1.0.67.ebuild')
-rw-r--r--sys-process/bpytop/bpytop-1.0.67.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-process/bpytop/bpytop-1.0.67.ebuild b/sys-process/bpytop/bpytop-1.0.67.ebuild
new file mode 100644
index 000000000000..635e16b769aa
--- /dev/null
+++ b/sys-process/bpytop/bpytop-1.0.67.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Linux/OSX/FreeBSD resource monitor"
+HOMEPAGE="https://github.com/aristocratos/bpytop"
+SRC_URI="https://github.com/aristocratos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/psutil-5.7.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/bpytop-1.0.63-tests.patch"
+)
+
+src_install() {
+ insinto "/usr/share/${PN}/themes"
+ doins bpytop-themes/*.theme
+ distutils-r1_src_install
+}