summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-06-06 22:31:43 +0530
committerJoonas Niilola <juippis@gentoo.org>2023-07-15 09:24:18 +0300
commitc2d834070ccb4ddc64f8e7af5e4bc092a384920c (patch)
tree41df1035d4770805d098446486ce0246aacea3a7 /sys-process/procenv/procenv-0.51-r1.ebuild
parentnet-firewall/rtsp-conntrack: Stabilize 5.3-r1 x86, #910350 (diff)
downloadgentoo-c2d834070ccb4ddc64f8e7af5e4bc092a384920c.tar.gz
gentoo-c2d834070ccb4ddc64f8e7af5e4bc092a384920c.tar.bz2
gentoo-c2d834070ccb4ddc64f8e7af5e4bc092a384920c.zip
sys-process/procenv: Fix call to undeclared function makedev
Closes: https://bugs.gentoo.org/898856 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31318 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-process/procenv/procenv-0.51-r1.ebuild')
-rw-r--r--sys-process/procenv/procenv-0.51-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-process/procenv/procenv-0.51-r1.ebuild b/sys-process/procenv/procenv-0.51-r1.ebuild
new file mode 100644
index 000000000000..d59d5338b0af
--- /dev/null
+++ b/sys-process/procenv/procenv-0.51-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="command-line utility to show process environment"
+HOMEPAGE="https://github.com/jamesodhunt/procenv"
+SRC_URI="https://github.com/jamesodhunt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-libs/check )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.45-flags.patch
+ "${FILESDIR}"/${PN}-0.51-musl-sysmacros.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}