summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-11 02:58:59 +0100
committerSam James <sam@gentoo.org>2021-08-11 03:05:18 +0100
commit1bf94ee45ca93a214be3fa2dda29b1d9fd90e0a9 (patch)
tree5491269837ff9c25c430428a33a51005b65ce2ee /sys-process
parentgnome-extra/synapse: update EAPI 6 -> 7, update caches (diff)
downloadgentoo-1bf94ee45ca93a214be3fa2dda29b1d9fd90e0a9.tar.gz
gentoo-1bf94ee45ca93a214be3fa2dda29b1d9fd90e0a9.tar.bz2
gentoo-1bf94ee45ca93a214be3fa2dda29b1d9fd90e0a9.zip
sys-process/htop: [QA] update caches
We can use xdg-utils unconditionally given it doesn't introduce a dependency. (When a package needing xdg-utils is installed, it'll update all the caches for us.) Closes: https://bugs.gentoo.org/787470 Thanks-to: Ionen Wolkens <ionen@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/htop/htop-3.0.5-r1.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/sys-process/htop/htop-3.0.5-r1.ebuild b/sys-process/htop/htop-3.0.5-r1.ebuild
index 82648c71eff3..ef78ad9c82ac 100644
--- a/sys-process/htop/htop-3.0.5-r1.ebuild
+++ b/sys-process/htop/htop-3.0.5-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
-inherit autotools linux-info python-any-r1
+inherit autotools linux-info python-any-r1 xdg-utils
DESCRIPTION="interactive process viewer"
HOMEPAGE="https://htop.dev/ https://github.com/htop-dev/htop"
@@ -65,3 +65,13 @@ src_configure() {
econf ${myeconfargs[@]}
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}