summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2024-03-31 12:59:20 -0700
committerJohn Helmert III <ajak@gentoo.org>2024-03-31 14:20:05 -0700
commit79d3a797c663ac615c346c6e593c098da267238f (patch)
treee47699dcb7978a319c25e64b374d37bd073b2254 /sys-process
parentprofiles, arm / 17.0 / musl: stable.mask gcc[sanitize] (diff)
downloadgentoo-79d3a797c663ac615c346c6e593c098da267238f.tar.gz
gentoo-79d3a797c663ac615c346c6e593c098da267238f.tar.bz2
gentoo-79d3a797c663ac615c346c6e593c098da267238f.zip
sys-process/glances: avoid distutils_enable_tests setup.py
Bug: https://bugs.gentoo.org/927530 Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/glances/glances-3.3.0-r1.ebuild8
-rw-r--r--sys-process/glances/glances-3.4.0.3.ebuild8
2 files changed, 12 insertions, 4 deletions
diff --git a/sys-process/glances/glances-3.3.0-r1.ebuild b/sys-process/glances/glances-3.3.0-r1.ebuild
index 84279372149c..7b155a7902b5 100644
--- a/sys-process/glances/glances-3.3.0-r1.ebuild
+++ b/sys-process/glances/glances-3.3.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -35,7 +35,7 @@ PATCHES=(
"${FILESDIR}/${PN}-3.2.5-disable-update-check.patch"
)
-distutils_enable_tests setup.py
+distutils_enable_tests unittest
distutils_enable_sphinx docs --no-autodoc
pkg_setup() {
@@ -55,6 +55,10 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
+python_test() {
+ "${EPYTHON}" unitest.py || die "tests failed with ${EPYTHON}"
+}
+
python_install_all() {
# add an intended file from original data set from setup.py to DOCS
local DOCS=( README.rst CONTRIBUTING.md conf/glances.conf )
diff --git a/sys-process/glances/glances-3.4.0.3.ebuild b/sys-process/glances/glances-3.4.0.3.ebuild
index acae2879ed60..c6302cc70e1c 100644
--- a/sys-process/glances/glances-3.4.0.3.ebuild
+++ b/sys-process/glances/glances-3.4.0.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -36,7 +36,7 @@ PATCHES=(
"${FILESDIR}/${PN}-3.4.0.3-disable-update-check.patch"
)
-distutils_enable_tests setup.py
+distutils_enable_tests unittest
distutils_enable_sphinx docs --no-autodoc
pkg_setup() {
@@ -56,6 +56,10 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
+python_test() {
+ "${EPYTHON}" unitest.py || echo "tests failed with ${EPYTHON}"
+}
+
python_install_all() {
# add an intended file from original data set from setup.py to DOCS
local DOCS=( README.rst CONTRIBUTING.md conf/glances.conf )