summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_flvx
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_flvx')
-rw-r--r--www-apache/mod_flvx/Manifest1
-rw-r--r--www-apache/mod_flvx/files/20_mod_flvx.conf11
-rw-r--r--www-apache/mod_flvx/metadata.xml5
-rw-r--r--www-apache/mod_flvx/mod_flvx-0.0.1-r1.ebuild22
4 files changed, 39 insertions, 0 deletions
diff --git a/www-apache/mod_flvx/Manifest b/www-apache/mod_flvx/Manifest
new file mode 100644
index 000000000000..67abd450ace6
--- /dev/null
+++ b/www-apache/mod_flvx/Manifest
@@ -0,0 +1 @@
+DIST mod_flvx-0.0.1.tar.bz2 1636 SHA256 bfcd82f5782f86577124ab88339762fe08e3e5a108e80bb56a20e12a6cc951c2
diff --git a/www-apache/mod_flvx/files/20_mod_flvx.conf b/www-apache/mod_flvx/files/20_mod_flvx.conf
new file mode 100644
index 000000000000..72096ca68e38
--- /dev/null
+++ b/www-apache/mod_flvx/files/20_mod_flvx.conf
@@ -0,0 +1,11 @@
+<IfDefine FLVX>
+ LoadModule flvx_module modules/mod_flvx.so
+
+ # Avoiding AddHandler directive for security
+ # https://bugs.gentoo.org/show_bug.cgi?id=544572
+ <FilesMatch "\.flv$">
+ SetHandler flv-stream
+ </FilesMatch>
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_flvx/metadata.xml b/www-apache/mod_flvx/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/www-apache/mod_flvx/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/www-apache/mod_flvx/mod_flvx-0.0.1-r1.ebuild b/www-apache/mod_flvx/mod_flvx-0.0.1-r1.ebuild
new file mode 100644
index 000000000000..63b7bf3db305
--- /dev/null
+++ b/www-apache/mod_flvx/mod_flvx-0.0.1-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils apache-module
+
+DESCRIPTION="mod_flvx allows to seek inside FLV files for streaming purposes"
+HOMEPAGE="http://journal.paul.querna.org/articles/2006/07/11/mod_flvx/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+APACHE2_MOD_CONF="20_${PN}"
+APACHE2_MOD_DEFINE="FLVX"
+
+need_apache2