summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2019-03-20 20:51:02 +0100
committerDirkjan Ochtman <djc@gentoo.org>2019-03-20 20:51:18 +0100
commit65ca8c91bdc54d11a80868489c03c0ab8e17afcf (patch)
tree9245058892aa84bc1e32f7764baa8d10f8ebd30c /www-apache/mod_wsgi/mod_wsgi-4.6.5.ebuild
parentnet-im/telegram-desktop-bin: Version bump (v1.6.1) (diff)
downloadgentoo-65ca8c91bdc54d11a80868489c03c0ab8e17afcf.tar.gz
gentoo-65ca8c91bdc54d11a80868489c03c0ab8e17afcf.tar.bz2
gentoo-65ca8c91bdc54d11a80868489c03c0ab8e17afcf.zip
www-apache/mod_wsgi: version bump to 4.6.5
Closes: https://bugs.gentoo.org/show_bug.cgi?id=673526 Signed-off-by: Dirkjan Ochtman <djc@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'www-apache/mod_wsgi/mod_wsgi-4.6.5.ebuild')
-rw-r--r--www-apache/mod_wsgi/mod_wsgi-4.6.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/www-apache/mod_wsgi/mod_wsgi-4.6.5.ebuild b/www-apache/mod_wsgi/mod_wsgi-4.6.5.ebuild
new file mode 100644
index 000000000000..959f38d461bb
--- /dev/null
+++ b/www-apache/mod_wsgi/mod_wsgi-4.6.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5,6} )
+PYTHON_REQ_USE="threads"
+
+inherit apache-module eutils python-single-r1
+
+DESCRIPTION="An Apache2 module for running Python WSGI applications"
+HOMEPAGE="https://github.com/GrahamDumpleton/mod_wsgi"
+SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}"
+
+APACHE2_MOD_CONF="70_${PN}"
+APACHE2_MOD_DEFINE="WSGI"
+APACHE2_MOD_FILE="${S}/src/server/.libs/${PN}.so"
+
+DOCFILES="README.rst"
+
+need_apache2
+
+src_configure() {
+ econf --with-apxs=${APXS} --with-python=${PYTHON}
+}
+
+src_compile() {
+ default
+}