summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-03-16 08:05:16 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-03-16 08:05:16 +0200
commit50be345ae56c3306ba8e2fcdd95b17bc44abce22 (patch)
tree078b2598bca574792e9db9fd471db3e0d3afc20b /www-apps/drupal
parentdev-python/ytmusicapi: Use pypi.eclass (diff)
downloadgentoo-50be345ae56c3306ba8e2fcdd95b17bc44abce22.tar.gz
gentoo-50be345ae56c3306ba8e2fcdd95b17bc44abce22.tar.bz2
gentoo-50be345ae56c3306ba8e2fcdd95b17bc44abce22.zip
www-apps/drupal: add 7.95
Security update. Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps/drupal')
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-7.95.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index c0257cc9add7..5ae1d31811d4 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,4 +1,5 @@
DIST drupal-10.0.2.tar.gz 17411661 BLAKE2B c7a9a98f1e8c120486c1a6bd17986b3e99c1e51113969413eb557f657fa3415f65b819a70d08be7c543b6609cba2881b18fa69ce77fe8b3764d9a4a12f569e04 SHA512 19f3f2459c8d2d54647f43db614cd493cb6f068d107678bb6c36823407fe815db71b7919fe755f40fb10c3697afb07e20c93fe47098de88f9248f18cf901da80
DIST drupal-7.91.tar.gz 3369203 BLAKE2B 202b3cbcbb25bb92f056c15cb8f697038caacdd62497de02b7e0036dc5dd5ac6e9b12c67620b753a5fbe8440e5883aec3061a626d753d9cca4f48b6d6358b3fc SHA512 da38735563cf5a76f432907b61943339b9d7f218e5abe5b5187138a470b545db14e23bb708fa53adc0853f9b46b34242e7eae3222e53b62fdafef29b2b476169
+DIST drupal-7.95.tar.gz 3380331 BLAKE2B 03b7434ef323cd8c26349ae11b65835a30dfb131f5fea36b6ec856d77a57756886fca79ad4f6ef033ab2716713993dcad331c96f99a5291e9083b8151652aa13 SHA512 7e013adc687ea263ff63eecee876367d5a2e4467a44fc4cc0d14a54f82d21b66069aa0ef7123370cdaf0d051a6c2fc870f359d2f2d657a59b41506e7dec8ad84
DIST drupal-9.4.10.tar.gz 21631038 BLAKE2B 635bca79c8ac0230205eb4eb11b4e790d49a3359c0fc1f535b936535b8541de71f0319806da221a9179b0b13c8f3d28ccf0f4d7c9088e459d9ff8274b3965b58 SHA512 befefe68ef0b6818ba9637fea2b007119483b431950cf0d81090d27b1e1672ab8c84be46ea1b083acf7dc4898bd4cfb294cd74a21cd5105cccef3d285c357739
DIST drupal-9.5.2.tar.gz 22552415 BLAKE2B f364faefa537e43a908ad7a4aab689643ef1ddf036881a4167b0681eeb0e8d0fa657037f059475b854f5e1965e670834bdc49cbd7bc8b5e4123ae9fa00423351 SHA512 a78637076db8034abb26e8c271db363ce3f20aa095f44b411ed2c3556bf102278a002ede68a386761d22004c65b9524ed473ac1a6c4e41ac6969b360179afde6
diff --git a/www-apps/drupal/drupal-7.95.ebuild b/www-apps/drupal/drupal-7.95.ebuild
new file mode 100644
index 000000000000..83823c1abd94
--- /dev/null
+++ b/www-apps/drupal/drupal-7.95.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+ virtual/httpd-php
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt INSTALL.mysql.txt INSTALL.pgsql.txt INSTALL.sqlite.txt UPGRADE.txt "
+ dodoc ${docs}
+ rm -f ${docs} INSTALL COPYRIGHT.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+}