summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2016-01-26 23:02:09 +0300
committerMaxim Koltsov <maksbotan@gentoo.org>2016-01-26 23:05:46 +0300
commit3ab430380cf9887c09753890e28bfb96c05e367a (patch)
tree7c1420b70d86d1ad38bd8e986f63aec2e4b608d6 /www-apps/radicale/radicale-1.1.1.ebuild
parentnet-analyzer/metasploit: fix repoman warning (diff)
downloadgentoo-3ab430380cf9887c09753890e28bfb96c05e367a.tar.gz
gentoo-3ab430380cf9887c09753890e28bfb96c05e367a.tar.bz2
gentoo-3ab430380cf9887c09753890e28bfb96c05e367a.zip
www-apps/radicale: add to tree, reworking Sunrise ebuild
Package-Manager: portage-2.2.27
Diffstat (limited to 'www-apps/radicale/radicale-1.1.1.ebuild')
-rw-r--r--www-apps/radicale/radicale-1.1.1.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/www-apps/radicale/radicale-1.1.1.ebuild b/www-apps/radicale/radicale-1.1.1.ebuild
new file mode 100644
index 000000000000..6ac4c3b39574
--- /dev/null
+++ b/www-apps/radicale/radicale-1.1.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit eutils distutils-r1 user
+
+MY_PN="Radicale"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A simple CalDAV calendar server"
+HOMEPAGE="http://www.radicale.org/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+RDIR=/var/lib/radicale
+LDIR=/var/log/radicale
+
+PATCHES=( "${FILESDIR}"/${P}-config.patch )
+
+pkg_setup() {
+ enewgroup radicale
+ enewuser radicale -1 -1 ${RDIR} radicale
+}
+
+python_install_all() {
+ rm README* || die
+
+ # init file
+ newinitd "${FILESDIR}"/radicale.init.d radicale
+
+ # directories
+ diropts -m0750
+ dodir ${RDIR}
+ fowners radicale:radicale ${RDIR}
+ diropts -m0755
+ dodir ${LDIR}
+ fowners radicale:radicale ${LDIR}
+
+ # config file
+ insinto /etc/${PN}
+ doins config logging
+
+ # fcgi and wsgi files
+ exeinto /usr/share/${PN}
+ doexe radicale.wsgi
+ doexe radicale.fcgi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ einfo "A sample WSGI script has been put into ${ROOT}usr/share/${PN}."
+ einfo "You will also find there an example FastCGI script."
+
+ einfo "Radicale supports different authentication backends that depend on external libraries."
+ einfo "Please install"
+ optfeature "LDAP auth" dev-python/python-ldap
+ optfeature "PAM auth" dev-python/python-pam
+ optfeature "HTTP auth" dev-python/requests
+ optfeature "FastCGI mode" dev-python/flup
+ optfeature "Database storage backend" dev-python/sqlalchemy
+ einfo "Please note that some of these libraries are Python 2 only."
+}