summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/webdavcgi/webdavcgi-0.8.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/webdavcgi/webdavcgi-0.8.3.ebuild')
-rw-r--r--www-apps/webdavcgi/webdavcgi-0.8.3.ebuild108
1 files changed, 108 insertions, 0 deletions
diff --git a/www-apps/webdavcgi/webdavcgi-0.8.3.ebuild b/www-apps/webdavcgi/webdavcgi-0.8.3.ebuild
new file mode 100644
index 000000000000..57e54f1f15a4
--- /dev/null
+++ b/www-apps/webdavcgi/webdavcgi-0.8.3.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs webapp
+
+DESCRIPTION="A Perl CGI for accessing and sharing files, or calendar/addressbooks via WebDAV"
+HOMEPAGE="http://webdavcgi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+WEBAPP_MANUAL_SLOT="yes"
+KEYWORDS="~amd64"
+IUSE="mysql postgres rcs samba +sqlite +suid"
+
+DEPEND=""
+RDEPEND="dev-perl/Archive-Zip
+ dev-perl/File-Copy-Link
+ dev-perl/PerlIO-gzip
+ dev-perl/Quota
+ dev-perl/TimeDate
+ dev-perl/URI
+ dev-perl/UUID-Tiny
+ dev-perl/XML-Simple
+ media-gfx/graphicsmagick[perl]
+ mysql? ( dev-perl/DBD-mysql )
+ virtual/perl-Module-Load
+ postgres? ( dev-perl/DBD-Pg )
+ rcs? ( dev-perl/Rcs )
+ samba? ( dev-perl/Filesys-SmbClient )
+ sqlite? ( dev-perl/DBD-SQLite )
+ dev-perl/CGI
+ virtual/perl-File-Spec"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+CGIBINDIR="cgi-bin"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-logout-var-expansion.patch"
+}
+
+src_compile() {
+ if use suid; then
+ # There are several webdavwrappers, TODO: make it configureable
+ export WEBDAVWRAPPER="webdavwrapper"
+
+ $(tc-getCC) ${LDFLAGS} ${CFLAGS} \
+ -o "${CGIBINDIR}/${WEBDAVWRAPPER}" \
+ helper/webdavwrapper.c || die "compile ${WEBDAVWRAPPER} failed"
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local htdocsDir='htdocs'
+ local confDir='etc'
+
+ local installDirs="$confDir lib locale"
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r "${htdocsDir}"/*
+
+ exeinto "${MY_CGIBINDIR}"
+ newexe "${CGIBINDIR}/logout-dist" logout
+
+ doexe "${CGIBINDIR}/webdav.pl"
+ use suid && doexe "${CGIBINDIR}/${WEBDAVWRAPPER}"
+
+ local currentDir
+ for currentDir in ${installDirs}; do
+ dodir "${MY_HOSTROOTDIR}/${currentDir}"
+ insinto "${MY_HOSTROOTDIR}/${currentDir}"
+ doins -r "${currentDir}"/*
+ done
+
+ webapp_configfile "${MY_HOSTROOTDIR}/${confDir}"/{webdav.conf-dist,mime.types}
+
+ use mysql && webapp_sqlscript mysql sql/mysql.sql
+ use postgres && webapp_sqlscript postgres sql/postgresql.sql
+
+ dodoc CHANGELOG TODO
+ dohtml -r doc/*
+
+ webapp_hook_script "${FILESDIR}/reconfig"
+
+ webapp_src_install
+
+ # In order to change the user and group ID at runtime, the webdavwrapper
+ # needs to be run as root (set-user-ID and set-group-ID bit)
+ if use suid; then
+ einfo "Setting SUID and SGID bit for ${WEBDAVWRAPPER}"
+ fowners root:root "${MY_CGIBINDIR}/${WEBDAVWRAPPER}"
+ fperms 6755 "${MY_CGIBINDIR}/${WEBDAVWRAPPER}"
+ webapp_postinst_txt en "${FILESDIR}/postinstall-${WEBDAVWRAPPER}-en.txt"
+ webapp_hook_script "${FILESDIR}/reconfig-suid"
+ else
+ ewarn "You have the 'suid' USE flag disabled"
+ ewarn "WebDAV CGI won't be able to switch user ids"
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+ fi
+}