summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-07-18 08:39:59 +0200
committerHans de Graaff <graaff@gentoo.org>2023-07-18 09:23:04 +0200
commit5136ac68079955fe732792e154ead96673441fe7 (patch)
tree34e7676aad61623e6fa9f2e94f572db33ac4ca45 /www-apps
parentwww-apps/nanoc-core: drop 4.12.14, 4.12.15 (diff)
downloadgentoo-5136ac68079955fe732792e154ead96673441fe7.tar.gz
gentoo-5136ac68079955fe732792e154ead96673441fe7.tar.bz2
gentoo-5136ac68079955fe732792e154ead96673441fe7.zip
www-apps/jekyll-sitemap: update EAPI 7 -> 8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/jekyll-sitemap/jekyll-sitemap-1.4.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/www-apps/jekyll-sitemap/jekyll-sitemap-1.4.0-r1.ebuild b/www-apps/jekyll-sitemap/jekyll-sitemap-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..f535799e02be
--- /dev/null
+++ b/www-apps/jekyll-sitemap/jekyll-sitemap-1.4.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md History.markdown"
+
+RUBY_FAKEGEM_GEMSPEC="jekyll-sitemap.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Automatically generate a sitemap.xml for your Jekyll site"
+HOMEPAGE="https://github.com/jekyll/jekyll-sitemap"
+SRC_URI="https://github.com/jekyll/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "=www-apps/jekyll-4*"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -type f -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}