summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2021-03-13 10:10:24 +0100
committerCédric Krier <cedk@gentoo.org>2021-03-13 10:10:48 +0100
commit745748b6f1e00d6a9080be1280c812aa7fe2c10e (patch)
tree53eafa8c59af24fd57b7b9ab5d90b8d0cdc4a025 /www-apps
parentdev-lang/xsb: fix build with autoconf-2.71 (diff)
downloadgentoo-745748b6f1e00d6a9080be1280c812aa7fe2c10e.tar.gz
gentoo-745748b6f1e00d6a9080be1280c812aa7fe2c10e.tar.bz2
gentoo-745748b6f1e00d6a9080be1280c812aa7fe2c10e.zip
www-apps/roundup: add support for python 3.9
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Cédric Krier <cedk@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/roundup/roundup-2.0.0.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/www-apps/roundup/roundup-2.0.0.ebuild b/www-apps/roundup/roundup-2.0.0.ebuild
index f1857def1d4b..335af1be6ac9 100644
--- a/www-apps/roundup/roundup-2.0.0.ebuild
+++ b/www-apps/roundup/roundup-2.0.0.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..8} )
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
MY_P=${P/_/}
@@ -36,6 +37,8 @@ RDEPEND="${DEPEND}
DOCS="CHANGES.txt doc/*.txt"
+distutils_enable_tests pytest
+
python_install_all() {
distutils-r1_python_install_all
rm -r "${ED}"/usr/share/doc/${PN} || die