summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2024-06-21 10:41:29 +0200
committerViorel Munteanu <ceamac@gentoo.org>2024-06-23 10:13:19 +0300
commitf24de92501c5b47ddee72d5cf303139085d34714 (patch)
tree29b735edc4a11f98102bf7814c50b4ca2ccbaacc /www-apps
parentdev-ml/labltk: depends on new ocaml-5 (diff)
downloadgentoo-f24de92501c5b47ddee72d5cf303139085d34714.tar.gz
gentoo-f24de92501c5b47ddee72d5cf303139085d34714.tar.bz2
gentoo-f24de92501c5b47ddee72d5cf303139085d34714.zip
www-apps/rutorrent: bump version to 4.3.4
Signed-off-by: Henning Schild <henning@hennsch.de> Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/rutorrent/Manifest1
-rw-r--r--www-apps/rutorrent/rutorrent-4.3.4.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/www-apps/rutorrent/Manifest b/www-apps/rutorrent/Manifest
index 19fdea124dd3..2874d19de14c 100644
--- a/www-apps/rutorrent/Manifest
+++ b/www-apps/rutorrent/Manifest
@@ -1,2 +1,3 @@
DIST rutorrent-4.2.10.tar.gz 2362233 BLAKE2B ea2b1b928e1a7c933ad6e85f5a18810d3f4bf11911da2926e26ba0329b54049dee24a456d0dedd98d106b3b9b460c791eae65a222cbe54ac0c2a49634b6b65a8 SHA512 b57e95591b835fd8d0c0e9acdf9c23dbaf6a37542c46397794da625edd02524af508510e0396308ddfe024d37c92e493134a13aae9dd28c5c642cdbd8d9264a5
DIST rutorrent-4.3.3.tar.gz 2377736 BLAKE2B ae07dce8c13268403a47ef20a3920228028578991b7325b808885e4576e4883859eb49dff6e6d0d0750ed1b58e900c6b8f4c646018b1b16ca5d0d919e3011971 SHA512 0301f512f8adb86a332dacac200c83cf49f0d532eb5e5206b137587a219914591932a801e9c711af60b1e91a430ed09ec99157c2a558cdf80828828e70eb0cb7
+DIST rutorrent-4.3.4.tar.gz 2377757 BLAKE2B 476026f255d22bf39c94284556403e7cc3ec9ed6dc1ed04f25ac6c82c14e7be32c17dca4e542cc8354673dbf572d1b1ebf0d6af3f013b16fae07cdf31aa4a01b SHA512 b141e58584d71ec42dc6c81b19036f9927afe16c79b74a6d881ad35946fe9e1b5c9f5bdbe99b1619396b59a08501e9123e9171da50e337cea8ad05daa7a76795
diff --git a/www-apps/rutorrent/rutorrent-4.3.4.ebuild b/www-apps/rutorrent/rutorrent-4.3.4.ebuild
new file mode 100644
index 000000000000..97453fadf5c8
--- /dev/null
+++ b/www-apps/rutorrent/rutorrent-4.3.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp optfeature
+
+DESCRIPTION="ruTorrent is a front-end for the popular Bittorrent client rTorrent"
+HOMEPAGE="https://github.com/Novik/ruTorrent"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Novik/ruTorrent.git"
+else
+ SRC_URI="https://github.com/Novik/ruTorrent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~x86"
+ S="${WORKDIR}/ruTorrent-${PV}"
+fi
+
+LICENSE="GPL-2+ MIT"
+
+RDEPEND="
+ dev-lang/php[xml,gd]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ rm -r .github || die
+ find . \( -name .gitignore -o -name .gitmodules \) -type f -delete || die
+ if [[ ${PV} == 9999 ]]; then
+ rm -r .git .gitattributes || die
+ fi
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # can not use fperms beacuse of globbing
+ chmod +x "${ED}${MY_HTDOCSDIR}"/plugins/*/*.sh \
+ "${ED}${MY_HTDOCSDIR}"/php/test.sh || die "chmod failed"
+
+ keepdir "${MY_HTDOCSDIR}"/conf/users
+ keepdir "${MY_HTDOCSDIR}"/share/settings
+ keepdir "${MY_HTDOCSDIR}"/share/torrents
+ keepdir "${MY_HTDOCSDIR}"/share/users
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/conf
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/share
+
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/.htaccess
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/access.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/plugins.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/share/.htaccess
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ optfeature "Show audio file spectogram" media-sound/sox
+ optfeature "Display media file information" media-video/mediainfo
+ optfeature "Scrape Cloudflare based sites" dev-python/cloudscraper
+}