summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-02-09 12:06:28 -0500
committerMike Gilbert <floppym@gentoo.org>2018-02-09 12:06:43 -0500
commitc5ef3a4ebbd0f313b937288691447992bf842147 (patch)
treee7a459d83ba628722d7de5111d556466d6e9b978 /www-client/chromium
parentapp-emulation/docker: Version bump to 18.02.0 (diff)
downloadgentoo-c5ef3a4ebbd0f313b937288691447992bf842147.tar.gz
gentoo-c5ef3a4ebbd0f313b937288691447992bf842147.tar.bz2
gentoo-c5ef3a4ebbd0f313b937288691447992bf842147.zip
www-client/chromium: fix bundled ffmpeg configure script
Closes: https://bugs.gentoo.org/646658 Package-Manager: Portage-2.3.24_p18, Repoman-2.3.6_p99
Diffstat (limited to 'www-client/chromium')
-rw-r--r--www-client/chromium/chromium-64.0.3282.140.ebuild1
-rw-r--r--www-client/chromium/chromium-65.0.3315.3.ebuild1
-rw-r--r--www-client/chromium/files/chromium-ffmpeg-r0.patch21
3 files changed, 23 insertions, 0 deletions
diff --git a/www-client/chromium/chromium-64.0.3282.140.ebuild b/www-client/chromium/chromium-64.0.3282.140.ebuild
index f9d0c892ec16..1f79ba7bd6fa 100644
--- a/www-client/chromium/chromium-64.0.3282.140.ebuild
+++ b/www-client/chromium/chromium-64.0.3282.140.ebuild
@@ -151,6 +151,7 @@ PATCHES=(
"${FILESDIR}/chromium-cups-r0.patch"
"${FILESDIR}/chromium-clang-r2.patch"
"${FILESDIR}/chromium-angle-r0.patch"
+ "${FILESDIR}/chromium-ffmpeg-r0.patch"
)
pre_build_checks() {
diff --git a/www-client/chromium/chromium-65.0.3315.3.ebuild b/www-client/chromium/chromium-65.0.3315.3.ebuild
index b8011501a833..c2d2f2fcaf78 100644
--- a/www-client/chromium/chromium-65.0.3315.3.ebuild
+++ b/www-client/chromium/chromium-65.0.3315.3.ebuild
@@ -152,6 +152,7 @@ PATCHES=(
"${FILESDIR}/chromium-gn-r0.patch"
"${FILESDIR}/chromium-vulkan-r0.patch"
"${FILESDIR}/chromium-gcc-r0.patch"
+ "${FILESDIR}/chromium-ffmpeg-r0.patch"
)
pre_build_checks() {
diff --git a/www-client/chromium/files/chromium-ffmpeg-r0.patch b/www-client/chromium/files/chromium-ffmpeg-r0.patch
new file mode 100644
index 000000000000..40632235babc
--- /dev/null
+++ b/www-client/chromium/files/chromium-ffmpeg-r0.patch
@@ -0,0 +1,21 @@
+--- a/third_party/ffmpeg/chromium/scripts/build_ffmpeg.py
++++ b/third_party/ffmpeg/chromium/scripts/build_ffmpeg.py
+@@ -632,18 +632,8 @@
+ if 'win' not in target_os:
+ configure_flags['Common'].extend([
+ '--enable-pic',
+- '--cc=clang',
+- '--cxx=clang++',
+- '--ld=clang',
+ ])
+
+- # Clang Linux will use the first 'ld' it finds on the path, which will
+- # typically be the system one, so explicitly configure use of Clang's
+- # ld.lld, to ensure that things like cross-compilation and LTO work.
+- # This does not work for arm64, ia32 and is always used on mac.
+- if target_arch not in ['arm64', 'ia32'] and target_os != 'mac':
+- configure_flags['Common'].append('--extra-ldflags=-fuse-ld=lld')
+-
+ # Should be run on Mac.
+ if target_os == 'mac':
+ if host_os != 'mac':