summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-client/dwb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-client/dwb')
-rw-r--r--www-client/dwb/Manifest2
-rw-r--r--www-client/dwb/dwb-2013.03.30.ebuild58
-rw-r--r--www-client/dwb/dwb-2014.03.07-r1.ebuild50
-rw-r--r--www-client/dwb/dwb-2014.03.07.ebuild52
-rw-r--r--www-client/dwb/dwb-9999.ebuild55
-rw-r--r--www-client/dwb/files/dwb-2013.03.30-json-c.patch33
-rw-r--r--www-client/dwb/files/dwb-2013.03.30-verbose-build.patch99
-rw-r--r--www-client/dwb/files/dwb-2014.03.07-makefile.patch200
-rw-r--r--www-client/dwb/files/dwb-2014.03.07-verbose-build.patch159
-rw-r--r--www-client/dwb/metadata.xml13
10 files changed, 721 insertions, 0 deletions
diff --git a/www-client/dwb/Manifest b/www-client/dwb/Manifest
new file mode 100644
index 000000000000..fd8929d10e4a
--- /dev/null
+++ b/www-client/dwb/Manifest
@@ -0,0 +1,2 @@
+DIST dwb-2013.03.30.tar.gz 410020 SHA256 bb12964be76d991f7b71d6c917eeecc3b356784b4a74194ffbf5f643d6cf2312 SHA512 2e9fa8cb18cadd8a27783851a825011ba5662a9e1b8ae3109e354b30f2f9e439fafd6034888a2d4d8195c8ff10b9ea70651981ea00938efb48d01256130cf9a6 WHIRLPOOL 3bb598b132a70029f1bbed4b794ba97efce1849e7fd77ea11531f14f1dc978f81aee34f1afcdedaca50153eb980278080cac48219c0bc8d5e4fd8779a5dddc0b
+DIST dwb-2014.03.07.tar.gz 474179 SHA256 bfbe3e366b27c969876f9ee7954f138b1d49a270aa84a14ce43e01591ab69b62 SHA512 7d3eb353ab7f7aa50bd678c75d72d1bbab0e5831991a1f4a1b2c4a8e134ccc90ab699932f5fd64efba157049c4863f258e329738529b7e03e2a56da737ca03a1 WHIRLPOOL 1864778d89d7fade7bf1fbeea4c5adf99cb11d63a56d255706fb3d15f19c9b0ce77ec124ad406b01b7fde8d39764ebda1f4fa70ee106731dea8f796b4e38a3ce
diff --git a/www-client/dwb/dwb-2013.03.30.ebuild b/www-client/dwb/dwb-2013.03.30.ebuild
new file mode 100644
index 000000000000..08c43f7f9078
--- /dev/null
+++ b/www-client/dwb/dwb-2013.03.30.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Dynamic web browser based on WebKit and GTK+"
+HOMEPAGE="http://portix.bitbucket.org/dwb/"
+SRC_URI="https://www.bitbucket.org/portix/dwb/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples gtk3"
+
+RDEPEND=">=net-libs/libsoup-2.32:2.4
+ dev-libs/json-c
+ net-libs/gnutls
+ !gtk3? (
+ >=net-libs/webkit-gtk-1.8.0:2
+ x11-libs/gtk+:2
+ )
+ gtk3? (
+ >=net-libs/webkit-gtk-1.8.0:3
+ x11-libs/gtk+:3
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-verbose-build.patch
+ epatch "${FILESDIR}"/${P}-json-c.patch
+
+ sed -i '/^CFLAGS += -\(pipe\|g\|O2\)/d' config.mk || die
+}
+
+src_compile() {
+ local myconf
+ use gtk3 && myconf+=" GTK=3"
+
+ # uclibc and other systems don't have execinfo.h (bug #465170)
+ if ! (echo '#include <execinfo.h>' | $(tc-getCC) -E - &>/dev/null) ; then
+ myconf+=" WITHOUT_EXECINFO=1"
+ fi
+
+ emake CC="$(tc-getCC)" ${myconf}
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/www-client/dwb/dwb-2014.03.07-r1.ebuild b/www-client/dwb/dwb-2014.03.07-r1.ebuild
new file mode 100644
index 000000000000..0d96e6959035
--- /dev/null
+++ b/www-client/dwb/dwb-2014.03.07-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Dynamic web browser based on WebKit and GTK+"
+HOMEPAGE="http://portix.bitbucket.org/dwb/"
+SRC_URI="https://www.bitbucket.org/portix/dwb/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples gtk3"
+
+RDEPEND=">=net-libs/libsoup-2.32:2.4
+ dev-libs/json-c
+ net-libs/gnutls
+ !gtk3? (
+ >=net-libs/webkit-gtk-1.8.0:2
+ x11-libs/gtk+:2
+ )
+ gtk3? (
+ >=net-libs/webkit-gtk-1.8.0:3
+ x11-libs/gtk+:3
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ local myconf
+ use gtk3 && myconf+=" GTK=3"
+
+ emake CC="$(tc-getCC)" ${myconf}
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/www-client/dwb/dwb-2014.03.07.ebuild b/www-client/dwb/dwb-2014.03.07.ebuild
new file mode 100644
index 000000000000..47ad78a03dcf
--- /dev/null
+++ b/www-client/dwb/dwb-2014.03.07.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Dynamic web browser based on WebKit and GTK+"
+HOMEPAGE="http://portix.bitbucket.org/dwb/"
+SRC_URI="https://www.bitbucket.org/portix/dwb/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples gtk3"
+
+RDEPEND=">=net-libs/libsoup-2.32:2.4
+ dev-libs/json-c
+ net-libs/gnutls
+ !gtk3? (
+ >=net-libs/webkit-gtk-1.8.0:2
+ x11-libs/gtk+:2
+ )
+ gtk3? (
+ >=net-libs/webkit-gtk-1.8.0:3
+ x11-libs/gtk+:3
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-verbose-build.patch
+
+ sed -i '/^CFLAGS += -\(pipe\|g\|O2\)/d' config.mk || die
+}
+
+src_compile() {
+ local myconf
+ use gtk3 && myconf+=" GTK=3"
+
+ emake CC="$(tc-getCC)" ${myconf}
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/www-client/dwb/dwb-9999.ebuild b/www-client/dwb/dwb-9999.ebuild
new file mode 100644
index 000000000000..fcbf9152eb0f
--- /dev/null
+++ b/www-client/dwb/dwb-9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit git-r3 toolchain-funcs
+
+EGIT_REPO_URI="https://bitbucket.org/portix/dwb.git"
+
+DESCRIPTION="Dynamic web browser based on WebKit and GTK+"
+HOMEPAGE="http://portix.bitbucket.org/dwb/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="examples gtk3 libsecret"
+
+RDEPEND="
+ >=net-libs/libsoup-2.38:2.4
+ dev-libs/json-c
+ net-libs/gnutls
+ !gtk3? (
+ >=net-libs/webkit-gtk-1.8.0:2
+ x11-libs/gtk+:2
+ )
+ gtk3? (
+ >=net-libs/webkit-gtk-1.8.0:3
+ x11-libs/gtk+:3
+ )
+ libsecret? ( app-crypt/libsecret )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i "/^CFLAGS += -\(pipe\|g\|O2\)/d" config.mk || die
+}
+
+src_compile() {
+ local myconf
+ use gtk3 && myconf+=" GTK=3"
+ ! use libsecret && myconf+=" USE_LIB_SECRET=0"
+
+ emake CC="$(tc-getCC)" ${myconf}
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/www-client/dwb/files/dwb-2013.03.30-json-c.patch b/www-client/dwb/files/dwb-2013.03.30-json-c.patch
new file mode 100644
index 000000000000..fbd3b55de0d0
--- /dev/null
+++ b/www-client/dwb/files/dwb-2013.03.30-json-c.patch
@@ -0,0 +1,33 @@
+--- dwb-2013.03.30/config.mk
++++ dwb-2013.03.30/config.mk
+@@ -105,8 +105,18 @@
+ $(error Cannot find $(GNUTLS))
+ endif
+
++# >=json-c-0.11 renamed its library, pc file, and include dir
++# first check for >=0.11, if it doesn't exist check for <0.11
++ifeq ($(shell pkg-config --exists json-c && echo 1), 1)
++JSONC=json-c
++else
+ ifeq ($(shell pkg-config --exists json && echo 1), 1)
+-LIBS+=$(GNUTLS)
++JSONC=json
++endif
++endif
++
++ifdef JSONC
++LIBS+=$(JSONC)
+ else
+ $(error Cannot find json-c)
+ endif
+--- dwb-2013.03.30/src/util/Makefile
++++ dwb-2013.03.30/src/util/Makefile
+@@ -13,7 +13,7 @@
+ TRANSPORT_SECURITY_JSON=transport_security_state_static.json
+ TRANSPORT_SECURITY_CERTS=transport_security_state_static.certs
+
+-LIBS=glib-2.0 gnutls json
++LIBS=glib-2.0 gnutls $(JSONC)
+ CFLAGS+=$(shell pkg-config --cflags $(LIBS))
+ LDFLAGS=$(shell pkg-config --libs $(LIBS))
+
diff --git a/www-client/dwb/files/dwb-2013.03.30-verbose-build.patch b/www-client/dwb/files/dwb-2013.03.30-verbose-build.patch
new file mode 100644
index 000000000000..f986bc1b8ad3
--- /dev/null
+++ b/www-client/dwb/files/dwb-2013.03.30-verbose-build.patch
@@ -0,0 +1,99 @@
+--- dwb-2013.03.30/Makefile
++++ dwb-2013.03.30/Makefile
+@@ -14,17 +14,17 @@
+ $(TARGET): $(SUBDIRS:%=%.subdir-make)
+
+ %.subdir-make: $(SUBDIR_BUILD_FIRST:%=%.subdir-buildfirst)
+- @$(MAKE) $(MFLAGS) -C $*
++ $(MAKE) $(MFLAGS) -C $*
+
+ #$(SRCDIR)/%: $(SUBDIR_BUILD_FIRST:%=%.subdir-buildfirst)
+
+ %.subdir-buildfirst:
+- @$(MAKE) $(MFLAGS) -C $*
++ $(MAKE) $(MFLAGS) -C $*
+
+ clean: $(SUBDIRS:%=%.subdir-clean) $(SUBDIR_BUILD_FIRST:%=%.subdir-cleanfirst)
+
+ %.subdir-clean %.subdir-cleanfirst:
+- @$(MAKE) $(MFLAGS) clean -C $*
++ $(MAKE) $(MFLAGS) clean -C $*
+
+
+ install: $(TARGET) install-man install-data
+--- dwb-2013.03.30/src/Makefile
++++ dwb-2013.03.30/src/Makefile
+@@ -10,30 +10,25 @@
+ all: $(TARGET)
+
+ $(TARGET): $(OBJ)
+- @echo "$(CC) $@"
+- @$(CC) $(OBJ) -o $(TARGET) $(LDFLAGS)
++ $(CC) $(OBJ) -o $(TARGET) $(LDFLAGS)
+
+ -include $(OBJ:.o=.d)
+ -include $(DOBJ:.do=.dd)
+
+ %.o: %.c %.h config.h dwb.h
+- @echo "${CC} $<"
+- @$(CC) -c -o $@ $< $(CFLAGS) $(CPPFLAGS)
++ $(CC) -c -o $@ $< $(CFLAGS) $(CPPFLAGS)
+
+ debug: $(DTARGET)
+
+ deps.d: %.c %.h
+- @echo "$(CC) -MM $@"
+- @$(CC) $(CFLAGS) -MM $< -o $@
++ $(CC) $(CFLAGS) -MM $< -o $@
+
+
+ %.do: %.c %.h config.h
+- @echo "${CC} $<"
+- @$(CC) -c -o $@ $< $(DCFLAGS)
++ $(CC) -c -o $@ $< $(DCFLAGS)
+
+ $(DTARGET): $(DOBJ)
+- @echo "$(CC) $@"
+- @$(CC) $(DOBJ) -o $(DTARGET) $(LDFLAGS)
++ $(CC) $(DOBJ) -o $(DTARGET) $(LDFLAGS)
+
+ dependencies: $(DEPS)
+
+--- dwb-2013.03.30/src/util/Makefile
++++ dwb-2013.03.30/src/util/Makefile
+@@ -27,16 +27,14 @@
+ @./$(MKTLDS) < $(TLDS_IN) > $@
+
+ $(MKTLDS): $(MKTLDS_SRC)
+- @echo "${CC} $<"
+- @$(CC) -o $@ $< $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)
++ $(CC) -o $@ $< $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)
+
+ $(HSTS_PRELOAD): $(HSTS) $(TRANSPORT_SECURITY_CERTS) $(TRANSPORT_SECURITY_JSON)
+ @echo gen $(notdir $@)
+ @./$(HSTS) > $@
+
+ $(HSTS): $(HSTS).c
+- @echo "${CC} $<"
+- @$(CC) $(CFLAGS) $(CPPFLAGS) -o $(HSTS) $(HSTS).c $(LDFLAGS)
++ $(CC) $(CFLAGS) $(CPPFLAGS) -o $(HSTS) $(HSTS).c $(LDFLAGS)
+
+ clean:
+ $(RM) $(OUTFILES) $(GEN_TOOLS)
+--- dwb-2013.03.30/tools/Makefile
++++ dwb-2013.03.30/tools/Makefile
+@@ -22,12 +22,10 @@
+ all: $(TARGET)
+
+ $(TARGET): $(OBJ)
+- @echo $(CC) $@
+- @$(CC) $< -o $@ $(LDFLAGS)
++ $(CC) $< -o $@ $(LDFLAGS)
+
+ %.o: %.c
+- @echo $(CC) $<
+- @$(CC) $(CFLAGS) -c $< -o $@ $(CPPFLAGS)
++ $(CC) $(CFLAGS) -c $< -o $@ $(CPPFLAGS)
+
+ clean:
+ rm -f $(TARGET) $(OBJ)
diff --git a/www-client/dwb/files/dwb-2014.03.07-makefile.patch b/www-client/dwb/files/dwb-2014.03.07-makefile.patch
new file mode 100644
index 000000000000..2221c31fd335
--- /dev/null
+++ b/www-client/dwb/files/dwb-2014.03.07-makefile.patch
@@ -0,0 +1,200 @@
+--- dwb-2014.03.07/config.mk
++++ dwb-2014.03.07/config.mk
+@@ -146,12 +146,9 @@
+ CFLAGS := $(CFLAGS)
+ CFLAGS += -Wall
+ CFLAGS += -Werror=format-security
+-CFLAGS += -pipe
+ CFLAGS += --ansi
+ CFLAGS += -std=c99
+ CFLAGS += -D_POSIX_C_SOURCE='200112L'
+-CFLAGS += -O2
+-CFLAGS += -g
+ CFLAGS += -D_BSD_SOURCE
+ CFLAGS += -D_NETBSD_SOURCE
+ CFLAGS += -D__BSD_VISIBLE
+--- dwb-2014.03.07/dwbem/Makefile
++++ dwb-2014.03.07/dwbem/Makefile
+@@ -15,7 +15,7 @@
+
+ CFLAGS := $(CFLAGS)
+ CFLAGS += -std=c99
+-CFLAGS += -Wall -O2 -pedantic
++CFLAGS += -Wall -pedantic
+ CFLAGS += -Wextra -Werror=format-security
+ CFLAGS += $(shell pkg-config --cflags $(LIBS))
+ CFLAGS += -DSYSTEM_EXTENSION_DIR=\"$(SYSTEM_EXTENSION_DIR)\"
+@@ -27,12 +27,10 @@
+ all: $(TARGET)
+
+ $(TARGET): $(OBJ)
+- @echo $(CC) -o $@
+- @$(CC) $(OBJ) -o $@ $(LDFLAGS)
++ $(CC) $(OBJ) -o $@ $(LDFLAGS)
+
+ %.o: %.c
+- @echo $(CC) $<
+- @$(CC) $(CFLAGS) -c $< -o $@ $(CPPFLAGS)
++ $(CC) $(CFLAGS) -c $< -o $@ $(CPPFLAGS)
+
+ clean:
+ rm -f $(TARGET) $(OBJ)
+--- dwb-2014.03.07/dwbremote/Makefile
++++ dwb-2014.03.07/dwbremote/Makefile
+@@ -7,7 +7,7 @@
+ include $(BASE_DIR)/version.mk
+
+
+-CFLAGS += -Wall -pedantic -Werror -Wextra -std=c99 -Os
++CFLAGS += -Wall -pedantic -Wextra -std=c99
+ CFLAGS += -DVERSION=\"$(VERSION)\"
+ CFLAGS += -DNAME=\"$(NAME)\"
+ CFLAGS += -DCOPYRIGHT=\"$(COPYRIGHT)\"
+@@ -27,12 +27,10 @@
+ all: $(TARGET)
+
+ $(TARGET): $(SHARED_OBJ) main.o
+- @echo $(CC) -o $@
+- @$(CC) $(OBJ) -o $@ $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)
++ $(CC) $(OBJ) -o $@ $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)
+
+ %.o: %.c
+- @echo $(CC) $<
+- @$(CC) -c $< -o $@ $(CFLAGS) $(CPPFLAGS)
++ $(CC) -c $< -o $@ $(CFLAGS) $(CPPFLAGS)
+
+ debug:
+ make CFLAGS="$(DCFLAGS)"
+--- dwb-2014.03.07/exar/Makefile
++++ dwb-2014.03.07/exar/Makefile
+@@ -1,6 +1,6 @@
+ ORIG_CFLAGS := $(CFLAGS)
+
+-CFLAGS := -Wall -pedantic -Werror -Wextra -std=c99 -O2
++CFLAGS := -Wall -pedantic -Wextra -std=c99
+ CFLAGS += $(ORIG_CFLAGS)
+
+ DCFLAGS += -g -O0 -Wall -pedantic -Werror -Wextra -std=c99
+@@ -14,12 +14,10 @@
+ all: $(SHARED_OBJ)
+
+ $(TARGET): $(OBJ)
+- @echo $(CC) -o $@
+- @$(CC) $(OBJ) -o $@ $(CFLAGS) $(CPPFLAGS)
++ $(CC) $(OBJ) -o $@ $(CFLAGS) $(CPPFLAGS)
+
+ %.o: %.c
+- @echo $(CC) $<
+- @$(CC) -c $< -o $@ $(CFLAGS) $(CPPFLAGS)
++ $(CC) -c $< -o $@ $(CFLAGS) $(CPPFLAGS)
+
+ debug:
+ make CFLAGS="$(DCFLAGS)"
+--- dwb-2014.03.07/Makefile
++++ dwb-2014.03.07/Makefile
+@@ -14,18 +14,18 @@
+ $(TARGET): $(SUBDIRS:%=%.subdir-make)
+
+ %.subdir-make: $(SUBDIR_BUILD_FIRST:%=%.subdir-buildfirst)
+- @$(MAKE) $(MFLAGS) -C $*
++ $(MAKE) $(MFLAGS) -C $*
+
+ #$(SRCDIR)/%: $(SUBDIR_BUILD_FIRST:%=%.subdir-buildfirst)
+
+ %.subdir-buildfirst:
+- @$(MAKE) $(MFLAGS) -C $*
++ $(MAKE) $(MFLAGS) -C $*
+
+ clean: $(SUBDIRS:%=%.subdir-clean) $(SUBDIR_BUILD_FIRST:%=%.subdir-cleanfirst) $(SUBDIR_BUILD_LIB:%=%.subdir-cleanlib)
+ -$(RM) -r sandbox
+
+ %.subdir-clean %.subdir-cleanfirst %.subdir-cleanlib:
+- @$(MAKE) $(MFLAGS) clean -C $*
++ $(MAKE) $(MFLAGS) clean -C $*
+
+
+ install: $(TARGET) install-man install-data
+--- dwb-2014.03.07/scripts/lib/Makefile
++++ dwb-2014.03.07/scripts/lib/Makefile
+@@ -1,6 +1,6 @@
+ # See COPYING for copyright and license details
+ TARGETS := $(patsubst %.js.in, %.js, $(wildcard *.js.in))
+-CFLAGS := -std=c99 -Wall -Wextra -pedantic -Werror -O2
++CFLAGS += -std=c99 -Wall -Wextra -pedantic
+
+ all: $(TARGETS)
+
+@@ -9,7 +9,7 @@
+ @./minify $< $@
+
+ minify: minify.c
+- $(CC) $< -o $@ ${CFLAGS} ${CPPFLAGS}
++ $(CC) $< -o $@ ${CFLAGS} ${CPPFLAGS} ${LDFLAGS}
+
+ clean:
+ $(RM) $(TARGETS)
+--- dwb-2014.03.07/src/Makefile
++++ dwb-2014.03.07/src/Makefile
+@@ -26,30 +26,25 @@
+ all: $(TARGET)
+
+ $(TARGET): $(OBJ)
+- @echo $(CC) -o $@
+- @$(CC) $(OBJ) -o $(TARGET) $(LDFLAGS)
++ $(CC) $(OBJ) -o $(TARGET) $(LDFLAGS)
+
+ -include $(OBJ:.o=.d)
+ -include $(DOBJ:.do=.dd)
+
+ %.o: %.c %.h config.h dwb.h
+- @echo $(CC) $<
+- @$(CC) -c -o $@ $< $(CFLAGS) $(CPPFLAGS)
++ $(CC) -c -o $@ $< $(CFLAGS) $(CPPFLAGS)
+
+ debug: $(DTARGET)
+
+ deps.d: %.c %.h
+- @echo "$(CC) -MM $@"
+- @$(CC) $(CFLAGS) -MM $< -o $@
++ $(CC) $(CFLAGS) -MM $< -o $@
+
+
+ %.do: %.c %.h config.h
+- @echo "${CC} $<"
+- @$(CC) -c -o $@ $< $(DCFLAGS)
++ $(CC) -c -o $@ $< $(DCFLAGS)
+
+ $(DTARGET): $(DOBJ) ../exar/exar.o ../dwbremote/dwbremote.o
+- @echo "$(CC) $@"
+- @$(CC) $(DOBJ) ../exar/exar.o ../dwbremote/dwbremote.o -o $(DTARGET) $(LDFLAGS)
++ $(CC) $(DOBJ) ../exar/exar.o ../dwbremote/dwbremote.o -o $(DTARGET) $(LDFLAGS)
+
+ dependencies: $(DEPS)
+
+--- dwb-2014.03.07/src/util/Makefile
++++ dwb-2014.03.07/src/util/Makefile
+@@ -30,20 +30,16 @@
+ all: $(OUTFILES)
+
+ $(TLDS_H): $(TLDS_IN) $(MKTLDS)
+- @echo gen $(notdir $@)
+- @./$(MKTLDS) < $(TLDS_IN) > $@
++ ./$(MKTLDS) < $(TLDS_IN) > $@
+
+ $(MKTLDS): $(MKTLDS_SRC)
+- @echo $(CC) $<
+- @$(CC) -o $@ $< $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)
++ $(CC) -o $@ $< $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)
+
+ $(HSTS_PRELOAD): $(HSTS) $(TRANSPORT_SECURITY_CERTS) $(TRANSPORT_SECURITY_JSON)
+- @echo gen $(notdir $@)
+- @./$(HSTS) > $@
++ ./$(HSTS) > $@
+
+ $(HSTS): $(HSTS).c
+- @echo $(CC) $<
+- @$(CC) $(CFLAGS) $(CPPFLAGS) -o $(HSTS) $(HSTS).c $(LDFLAGS)
++ $(CC) $(CFLAGS) $(CPPFLAGS) -o $(HSTS) $(HSTS).c $(LDFLAGS)
+
+ clean:
+ $(RM) $(OUTFILES) $(GEN_TOOLS)
diff --git a/www-client/dwb/files/dwb-2014.03.07-verbose-build.patch b/www-client/dwb/files/dwb-2014.03.07-verbose-build.patch
new file mode 100644
index 000000000000..5d16a683ad36
--- /dev/null
+++ b/www-client/dwb/files/dwb-2014.03.07-verbose-build.patch
@@ -0,0 +1,159 @@
+--- dwb-2014.03.07/dwbem/Makefile
++++ dwb-2014.03.07/dwbem/Makefile
+@@ -27,12 +27,10 @@
+ all: $(TARGET)
+
+ $(TARGET): $(OBJ)
+- @echo $(CC) -o $@
+- @$(CC) $(OBJ) -o $@ $(LDFLAGS)
++ $(CC) $(OBJ) -o $@ $(LDFLAGS)
+
+ %.o: %.c
+- @echo $(CC) $<
+- @$(CC) $(CFLAGS) -c $< -o $@ $(CPPFLAGS)
++ $(CC) $(CFLAGS) -c $< -o $@ $(CPPFLAGS)
+
+ clean:
+ rm -f $(TARGET) $(OBJ)
+--- dwb-2014.03.07/dwbremote/Makefile
++++ dwb-2014.03.07/dwbremote/Makefile
+@@ -27,12 +27,10 @@
+ all: $(TARGET)
+
+ $(TARGET): $(SHARED_OBJ) main.o
+- @echo $(CC) -o $@
+- @$(CC) $(OBJ) -o $@ $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)
++ $(CC) $(OBJ) -o $@ $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)
+
+ %.o: %.c
+- @echo $(CC) $<
+- @$(CC) -c $< -o $@ $(CFLAGS) $(CPPFLAGS)
++ $(CC) -c $< -o $@ $(CFLAGS) $(CPPFLAGS)
+
+ debug:
+ make CFLAGS="$(DCFLAGS)"
+--- dwb-2014.03.07/exar/Makefile
++++ dwb-2014.03.07/exar/Makefile
+@@ -14,12 +14,10 @@
+ all: $(SHARED_OBJ)
+
+ $(TARGET): $(OBJ)
+- @echo $(CC) -o $@
+- @$(CC) $(OBJ) -o $@ $(CFLAGS) $(CPPFLAGS)
++ $(CC) $(OBJ) -o $@ $(CFLAGS) $(CPPFLAGS)
+
+ %.o: %.c
+- @echo $(CC) $<
+- @$(CC) -c $< -o $@ $(CFLAGS) $(CPPFLAGS)
++ $(CC) -c $< -o $@ $(CFLAGS) $(CPPFLAGS)
+
+ debug:
+ make CFLAGS="$(DCFLAGS)"
+--- dwb-2014.03.07/Makefile
++++ dwb-2014.03.07/Makefile
+@@ -14,18 +14,18 @@
+ $(TARGET): $(SUBDIRS:%=%.subdir-make)
+
+ %.subdir-make: $(SUBDIR_BUILD_FIRST:%=%.subdir-buildfirst)
+- @$(MAKE) $(MFLAGS) -C $*
++ $(MAKE) $(MFLAGS) -C $*
+
+ #$(SRCDIR)/%: $(SUBDIR_BUILD_FIRST:%=%.subdir-buildfirst)
+
+ %.subdir-buildfirst:
+- @$(MAKE) $(MFLAGS) -C $*
++ $(MAKE) $(MFLAGS) -C $*
+
+ clean: $(SUBDIRS:%=%.subdir-clean) $(SUBDIR_BUILD_FIRST:%=%.subdir-cleanfirst) $(SUBDIR_BUILD_LIB:%=%.subdir-cleanlib)
+ -$(RM) -r sandbox
+
+ %.subdir-clean %.subdir-cleanfirst %.subdir-cleanlib:
+- @$(MAKE) $(MFLAGS) clean -C $*
++ $(MAKE) $(MFLAGS) clean -C $*
+
+
+ install: $(TARGET) install-man install-data
+--- dwb-2014.03.07/scripts/lib/Makefile
++++ dwb-2014.03.07/scripts/lib/Makefile
+@@ -1,6 +1,6 @@
+ # See COPYING for copyright and license details
+ TARGETS := $(patsubst %.js.in, %.js, $(wildcard *.js.in))
+-CFLAGS := -std=c99 -Wall -Wextra -pedantic -Werror -O2
++CFLAGS += -std=c99 -Wall -Wextra -pedantic
+
+ all: $(TARGETS)
+
+@@ -9,7 +9,7 @@
+ @./minify $< $@
+
+ minify: minify.c
+- $(CC) $< -o $@ ${CFLAGS} ${CPPFLAGS}
++ $(CC) $< -o $@ ${CFLAGS} ${CPPFLAGS} ${LDFLAGS}
+
+ clean:
+ $(RM) $(TARGETS)
+--- dwb-2014.03.07/src/Makefile
++++ dwb-2014.03.07/src/Makefile
+@@ -26,30 +26,25 @@
+ all: $(TARGET)
+
+ $(TARGET): $(OBJ)
+- @echo $(CC) -o $@
+- @$(CC) $(OBJ) -o $(TARGET) $(LDFLAGS)
++ $(CC) $(OBJ) -o $(TARGET) $(LDFLAGS)
+
+ -include $(OBJ:.o=.d)
+ -include $(DOBJ:.do=.dd)
+
+ %.o: %.c %.h config.h dwb.h
+- @echo $(CC) $<
+- @$(CC) -c -o $@ $< $(CFLAGS) $(CPPFLAGS)
++ $(CC) -c -o $@ $< $(CFLAGS) $(CPPFLAGS)
+
+ debug: $(DTARGET)
+
+ deps.d: %.c %.h
+- @echo "$(CC) -MM $@"
+- @$(CC) $(CFLAGS) -MM $< -o $@
++ $(CC) $(CFLAGS) -MM $< -o $@
+
+
+ %.do: %.c %.h config.h
+- @echo "${CC} $<"
+- @$(CC) -c -o $@ $< $(DCFLAGS)
++ $(CC) -c -o $@ $< $(DCFLAGS)
+
+ $(DTARGET): $(DOBJ) ../exar/exar.o ../dwbremote/dwbremote.o
+- @echo "$(CC) $@"
+- @$(CC) $(DOBJ) ../exar/exar.o ../dwbremote/dwbremote.o -o $(DTARGET) $(LDFLAGS)
++ $(CC) $(DOBJ) ../exar/exar.o ../dwbremote/dwbremote.o -o $(DTARGET) $(LDFLAGS)
+
+ dependencies: $(DEPS)
+
+--- dwb-2014.03.07/src/util/Makefile
++++ dwb-2014.03.07/src/util/Makefile
+@@ -30,20 +30,16 @@
+ all: $(OUTFILES)
+
+ $(TLDS_H): $(TLDS_IN) $(MKTLDS)
+- @echo gen $(notdir $@)
+- @./$(MKTLDS) < $(TLDS_IN) > $@
++ ./$(MKTLDS) < $(TLDS_IN) > $@
+
+ $(MKTLDS): $(MKTLDS_SRC)
+- @echo $(CC) $<
+- @$(CC) -o $@ $< $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)
++ $(CC) -o $@ $< $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)
+
+ $(HSTS_PRELOAD): $(HSTS) $(TRANSPORT_SECURITY_CERTS) $(TRANSPORT_SECURITY_JSON)
+- @echo gen $(notdir $@)
+- @./$(HSTS) > $@
++ ./$(HSTS) > $@
+
+ $(HSTS): $(HSTS).c
+- @echo $(CC) $<
+- @$(CC) $(CFLAGS) $(CPPFLAGS) -o $(HSTS) $(HSTS).c $(LDFLAGS)
++ $(CC) $(CFLAGS) $(CPPFLAGS) -o $(HSTS) $(HSTS).c $(LDFLAGS)
+
+ clean:
+ $(RM) $(OUTFILES) $(GEN_TOOLS)
diff --git a/www-client/dwb/metadata.xml b/www-client/dwb/metadata.xml
new file mode 100644
index 000000000000..b7bf3a2e321f
--- /dev/null
+++ b/www-client/dwb/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version = '1.0' encoding = 'UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <use>
+ <flag name="gtk3">Link against <pkg>x11-libs/gtk+:3</pkg> instead of
+ <pkg>x11-libs/gtk+:2</pkg></flag>
+ <flag name="libsecret">Enable libsecret support to store login credentials</flag>
+ </use>
+</pkgmetadata>