summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2022-02-10 00:19:27 +0100
committerPiotr Karbowski <slashbeast@gentoo.org>2022-02-10 00:20:33 +0100
commit2ecd527b97c3966044d4828ac44cfcbc882ad789 (patch)
treeaae388c7f5a13d376208d28746946509693f4005 /www-client/firefox
parentdev-scheme/racket: bump to 8.4 (diff)
downloadgentoo-2ecd527b97c3966044d4828ac44cfcbc882ad789.tar.gz
gentoo-2ecd527b97c3966044d4828ac44cfcbc882ad789.tar.bz2
gentoo-2ecd527b97c3966044d4828ac44cfcbc882ad789.zip
www-client/firefox: 97.0: stub pip check.
Closes: https://bugs.gentoo.org/828999 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'www-client/firefox')
-rw-r--r--www-client/firefox/files/firefox-skip-pip-check.patch14
-rw-r--r--www-client/firefox/firefox-97.0.ebuild3
2 files changed, 17 insertions, 0 deletions
diff --git a/www-client/firefox/files/firefox-skip-pip-check.patch b/www-client/firefox/files/firefox-skip-pip-check.patch
new file mode 100644
index 000000000000..dba1056baf94
--- /dev/null
+++ b/www-client/firefox/files/firefox-skip-pip-check.patch
@@ -0,0 +1,14 @@
+diff --git a/python/mach/mach/site.py b/python/mach/mach/site.py
+index 8fef9bfaf8..61c3101c11 100644
+--- a/python/mach/mach/site.py
++++ b/python/mach/mach/site.py
+@@ -940,6 +940,9 @@ def _assert_pip_check(topsrcdir, pthfile_lines, virtualenv_name):
+ If there's an incompatibility, raise an exception and allow it to bubble up since
+ it will require user intervention to resolve.
+ """
++
++ return True
++
+ if os.environ.get(
+ f"MACH_SYSTEM_ASSERTED_COMPATIBLE_WITH_{virtualenv_name.upper()}_SITE", None
+ ):
diff --git a/www-client/firefox/firefox-97.0.ebuild b/www-client/firefox/firefox-97.0.ebuild
index 065a1f5c089e..1e4506d759ef 100644
--- a/www-client/firefox/firefox-97.0.ebuild
+++ b/www-client/firefox/firefox-97.0.ebuild
@@ -579,6 +579,9 @@ src_unpack() {
}
src_prepare() {
+ # Don't run pip check on the host that builds firefox.
+ eapply "${FILESDIR}"/firefox-skip-pip-check.patch
+
use lto && rm -v "${WORKDIR}"/firefox-patches/*-LTO-Only-enable-LTO-*.patch
eapply "${WORKDIR}/firefox-patches"