summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-13 01:01:41 +0000
committerSam James <sam@gentoo.org>2021-12-13 01:02:53 +0000
commit211da92099ddcbc7dae4ed5ddf1df1a40107ad06 (patch)
tree988518e2278279b382154fbcbff4a2f22dd7c599 /www-client/seamonkey
parentkde-frameworks/kio: update Manifest for 5.89 (tarball respun) (diff)
downloadgentoo-211da92099ddcbc7dae4ed5ddf1df1a40107ad06.tar.gz
gentoo-211da92099ddcbc7dae4ed5ddf1df1a40107ad06.tar.bz2
gentoo-211da92099ddcbc7dae4ed5ddf1df1a40107ad06.zip
www-client/seamonkey: Add USE=system-png
Since Seamonkey requires patched version of media-libs/libpng and the patches are known to break WebKit, provide the ability to build against vendored libpng in order to make it possible for the users to return to vanilla libpng. See-also: https://gitweb.gentoo.org/sites/projects/council.git/tree/meeting-logs/20211212.txt#n98 Bug: https://bugs.gentoo.org/824838 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-client/seamonkey')
-rw-r--r--www-client/seamonkey/metadata.xml1
-rw-r--r--www-client/seamonkey/seamonkey-2.53.8.1.ebuild6
-rw-r--r--www-client/seamonkey/seamonkey-2.53.9.1.ebuild6
-rw-r--r--www-client/seamonkey/seamonkey-2.53.9.ebuild6
4 files changed, 10 insertions, 9 deletions
diff --git a/www-client/seamonkey/metadata.xml b/www-client/seamonkey/metadata.xml
index 44ca1be0e3a4..f3fa056f0caa 100644
--- a/www-client/seamonkey/metadata.xml
+++ b/www-client/seamonkey/metadata.xml
@@ -19,6 +19,7 @@
<flag name="system-jpeg">Use the system-wide <pkg>media-libs/libjpeg-turbo</pkg> instead of bundled</flag>
<flag name="system-libevent">Use the system-wide <pkg>dev-libs/libevent</pkg> instead of bundled</flag>
<flag name="system-libvpx">Use the system-wide <pkg>media-libs/libvpx</pkg> instead of bundled</flag>
+ <flag name="system-png">Use the system-wide <pkg>media-libs/libpng</pkg> instead of bundled (requires APNG patches)</flag>
<flag name="system-sqlite">Use the system-wide <pkg>dev-db/sqlite</pkg> installation with secure-delete enabled</flag>
</use>
</pkgmetadata>
diff --git a/www-client/seamonkey/seamonkey-2.53.8.1.ebuild b/www-client/seamonkey/seamonkey-2.53.8.1.ebuild
index 7b2069c0c817..c6468ec65cd5 100644
--- a/www-client/seamonkey/seamonkey-2.53.8.1.ebuild
+++ b/www-client/seamonkey/seamonkey-2.53.8.1.ebuild
@@ -49,7 +49,7 @@ SRC_URI+="
LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
SLOT="0"
-SYSTEM_IUSE=( +system-{av1,harfbuzz,icu,jpeg,libevent,libvpx,sqlite} )
+SYSTEM_IUSE=( +system-{av1,harfbuzz,icu,jpeg,libevent,libvpx,png,sqlite} )
IUSE="+chatzilla cpu_flags_arm_neon +crypt dbus debug +gmp-autoupdate +ipc jack
lto pulseaudio +roaming selinux startup-notification test wifi"
IUSE+=" ${SYSTEM_IUSE[@]}"
@@ -81,7 +81,6 @@ COMMON_DEPEND="
>=dev-libs/nss-3.47.1
media-libs/fontconfig
>=media-libs/freetype-2.4.10
- >=media-libs/libpng-1.6.31:0=[apng]
>=media-libs/mesa-10.2:=
>=sys-libs/zlib-1.2.3
>=x11-libs/cairo-1.10[X]
@@ -123,6 +122,7 @@ COMMON_DEPEND="
system-jpeg? ( >=media-libs/libjpeg-turbo-1.2.1 )
system-libevent? ( >=dev-libs/libevent-2.0:0= )
system-libvpx? ( >=media-libs/libvpx-1.8.0:0=[postproc] )
+ system-png? ( >=media-libs/libpng-1.6.31:0=[apng] )
system-sqlite? ( >=dev-db/sqlite-3.31.0:3[secure-delete,debug=] )
wifi? (
kernel_linux? (
@@ -309,7 +309,6 @@ src_configure() {
mozconfig_annotate '' --libdir="${EPREFIX}"/usr/$(get_libdir)
mozconfig_annotate 'Gentoo default' --enable-system-hunspell
mozconfig_annotate '' --disable-crashreporter
- mozconfig_annotate 'Gentoo default' --with-system-png
mozconfig_annotate '' --enable-system-ffi
mozconfig_annotate '' --disable-gconf
mozconfig_annotate '' --with-intl-api
@@ -344,6 +343,7 @@ src_configure() {
mozconfig_use_with system-jpeg
mozconfig_use_with system-icu
mozconfig_use_with system-libvpx
+ mozconfig_use_with system-png
mozconfig_use_with system-harfbuzz
mozconfig_use_with system-harfbuzz system-graphite2
mozconfig_use_with system-av1
diff --git a/www-client/seamonkey/seamonkey-2.53.9.1.ebuild b/www-client/seamonkey/seamonkey-2.53.9.1.ebuild
index c766508bf961..e49acef90dcf 100644
--- a/www-client/seamonkey/seamonkey-2.53.9.1.ebuild
+++ b/www-client/seamonkey/seamonkey-2.53.9.1.ebuild
@@ -48,7 +48,7 @@ SRC_URI+="
LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
SLOT="0"
-SYSTEM_IUSE=( +system-{av1,harfbuzz,icu,jpeg,libevent,libvpx,sqlite} )
+SYSTEM_IUSE=( +system-{av1,harfbuzz,icu,jpeg,libevent,libvpx,png,sqlite} )
IUSE="+chatzilla cpu_flags_arm_neon +crypt dbus debug +gmp-autoupdate +ipc jack
lto pulseaudio +roaming selinux startup-notification test wifi"
IUSE+=" ${SYSTEM_IUSE[@]}"
@@ -80,7 +80,6 @@ COMMON_DEPEND="
>=dev-libs/nss-3.47.1
media-libs/fontconfig
>=media-libs/freetype-2.4.10
- >=media-libs/libpng-1.6.31:0=[apng]
>=media-libs/mesa-10.2:=
>=sys-libs/zlib-1.2.3
>=x11-libs/cairo-1.10[X]
@@ -122,6 +121,7 @@ COMMON_DEPEND="
system-jpeg? ( >=media-libs/libjpeg-turbo-1.2.1 )
system-libevent? ( >=dev-libs/libevent-2.0:0= )
system-libvpx? ( >=media-libs/libvpx-1.8.0:0=[postproc] )
+ system-png? ( >=media-libs/libpng-1.6.31:0=[apng] )
system-sqlite? ( >=dev-db/sqlite-3.33.0:3[secure-delete,debug=] )
wifi? (
kernel_linux? (
@@ -307,7 +307,6 @@ src_configure() {
mozconfig_annotate '' --libdir="${EPREFIX}"/usr/$(get_libdir)
mozconfig_annotate 'Gentoo default' --enable-system-hunspell
mozconfig_annotate '' --disable-crashreporter
- mozconfig_annotate 'Gentoo default' --with-system-png
mozconfig_annotate '' --enable-system-ffi
mozconfig_annotate '' --disable-gconf
mozconfig_annotate '' --with-intl-api
@@ -342,6 +341,7 @@ src_configure() {
mozconfig_use_with system-jpeg
mozconfig_use_with system-icu
mozconfig_use_with system-libvpx
+ mozconfig_use_with system-png
mozconfig_use_with system-harfbuzz
mozconfig_use_with system-harfbuzz system-graphite2
mozconfig_use_with system-av1
diff --git a/www-client/seamonkey/seamonkey-2.53.9.ebuild b/www-client/seamonkey/seamonkey-2.53.9.ebuild
index 0e2fbc4182c3..079f44cf3770 100644
--- a/www-client/seamonkey/seamonkey-2.53.9.ebuild
+++ b/www-client/seamonkey/seamonkey-2.53.9.ebuild
@@ -48,7 +48,7 @@ SRC_URI+="
LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
SLOT="0"
-SYSTEM_IUSE=( +system-{av1,harfbuzz,icu,jpeg,libevent,libvpx,sqlite} )
+SYSTEM_IUSE=( +system-{av1,harfbuzz,icu,jpeg,libevent,libvpx,png,sqlite} )
IUSE="+chatzilla cpu_flags_arm_neon +crypt dbus debug +gmp-autoupdate +ipc jack
lto pulseaudio +roaming selinux startup-notification test wifi"
IUSE+=" ${SYSTEM_IUSE[@]}"
@@ -80,7 +80,6 @@ COMMON_DEPEND="
>=dev-libs/nss-3.47.1
media-libs/fontconfig
>=media-libs/freetype-2.4.10
- >=media-libs/libpng-1.6.31:0=[apng]
>=media-libs/mesa-10.2:=
>=sys-libs/zlib-1.2.3
>=x11-libs/cairo-1.10[X]
@@ -122,6 +121,7 @@ COMMON_DEPEND="
system-jpeg? ( >=media-libs/libjpeg-turbo-1.2.1 )
system-libevent? ( >=dev-libs/libevent-2.0:0= )
system-libvpx? ( >=media-libs/libvpx-1.8.0:0=[postproc] )
+ system-png? ( >=media-libs/libpng-1.6.31:0=[apng] )
system-sqlite? ( >=dev-db/sqlite-3.33.0:3[secure-delete,debug=] )
wifi? (
kernel_linux? (
@@ -307,7 +307,6 @@ src_configure() {
mozconfig_annotate '' --libdir="${EPREFIX}"/usr/$(get_libdir)
mozconfig_annotate 'Gentoo default' --enable-system-hunspell
mozconfig_annotate '' --disable-crashreporter
- mozconfig_annotate 'Gentoo default' --with-system-png
mozconfig_annotate '' --enable-system-ffi
mozconfig_annotate '' --disable-gconf
mozconfig_annotate '' --with-intl-api
@@ -342,6 +341,7 @@ src_configure() {
mozconfig_use_with system-jpeg
mozconfig_use_with system-icu
mozconfig_use_with system-libvpx
+ mozconfig_use_with system-png
mozconfig_use_with system-harfbuzz
mozconfig_use_with system-harfbuzz system-graphite2
mozconfig_use_with system-av1