summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-01-28 09:38:16 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-01-28 09:45:17 +0200
commit3a7cdd9a5bd767ad195fb20d2fd2fb4e7097a40a (patch)
treecb02293aa9af0930915c0a9c57c50435960d7c87 /www-client
parentmail-client/thunderbird: Make cargo respect MAKEOPTS (diff)
downloadgentoo-3a7cdd9a5bd767ad195fb20d2fd2fb4e7097a40a.tar.gz
gentoo-3a7cdd9a5bd767ad195fb20d2fd2fb4e7097a40a.tar.bz2
gentoo-3a7cdd9a5bd767ad195fb20d2fd2fb4e7097a40a.zip
www-client/firefox: Make cargo respect MAKEOPTS
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/firefox-91.5.1.ebuild3
-rw-r--r--www-client/firefox/firefox-96.0.3.ebuild3
2 files changed, 6 insertions, 0 deletions
diff --git a/www-client/firefox/firefox-91.5.1.ebuild b/www-client/firefox/firefox-91.5.1.ebuild
index 626ac54e86e6..e2b258aa159d 100644
--- a/www-client/firefox/firefox-91.5.1.ebuild
+++ b/www-client/firefox/firefox-91.5.1.ebuild
@@ -580,6 +580,9 @@ src_prepare() {
# Allow user to apply any additional patches without modifing ebuild
eapply_user
+ # Make cargo respect MAKEOPTS
+ export CARGO_BUILD_JOBS="$(makeopts_jobs)"
+
# Make LTO respect MAKEOPTS
sed -i \
-e "s/multiprocessing.cpu_count()/$(makeopts_jobs)/" \
diff --git a/www-client/firefox/firefox-96.0.3.ebuild b/www-client/firefox/firefox-96.0.3.ebuild
index 8d7e2c1c0e9e..8b24b1dfafe2 100644
--- a/www-client/firefox/firefox-96.0.3.ebuild
+++ b/www-client/firefox/firefox-96.0.3.ebuild
@@ -582,6 +582,9 @@ src_prepare() {
# Allow user to apply any additional patches without modifing ebuild
eapply_user
+ # Make cargo respect MAKEOPTS
+ export CARGO_BUILD_JOBS="$(makeopts_jobs)"
+
# Make LTO respect MAKEOPTS
sed -i \
-e "s/multiprocessing.cpu_count()/$(makeopts_jobs)/" \