summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2023-10-26 01:42:16 +1000
committerMike Gilbert <floppym@gentoo.org>2023-10-25 12:15:33 -0400
commitbbc364de83bccc57ee8d3c7a366b859096bd3e90 (patch)
tree1dc73cf72771fd4ab1c097f10cab9a2d6536ccff /www-client
parentwww-client/chromium: drop 117.0.5938.149, 118.0.5993.70 (diff)
downloadgentoo-bbc364de83bccc57ee8d3c7a366b859096bd3e90.tar.gz
gentoo-bbc364de83bccc57ee8d3c7a366b859096bd3e90.tar.bz2
gentoo-bbc364de83bccc57ee8d3c7a366b859096bd3e90.zip
www-client/chromium: add gn test to 119/beta
Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/chromium-119.0.6045.33.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/www-client/chromium/chromium-119.0.6045.33.ebuild b/www-client/chromium/chromium-119.0.6045.33.ebuild
index 41323a32a07d..aeab0b5fad59 100644
--- a/www-client/chromium/chromium-119.0.6045.33.ebuild
+++ b/www-client/chromium/chromium-119.0.6045.33.ebuild
@@ -14,6 +14,7 @@ PYTHON_REQ_USE="xml(+)"
LLVM_MAX_SLOT=17
LLVM_MIN_SLOT=16
MIN_GCC_VER=12
+GN_MIN_VER=0.2122
VIRTUALX_REQUIRED="pgo"
@@ -187,7 +188,7 @@ BDEPEND="
$(depend_clang_llvm_versions ${LLVM_MIN_SLOT} ${LLVM_MAX_SLOT})
)
dev-lang/perl
- >=dev-util/gn-0.2122
+ >=dev-util/gn-${GN_MIN_VER}
>=dev-util/gperf-3.0.3
>=dev-util/ninja-1.7.2
dev-vcs/git
@@ -318,6 +319,10 @@ pkg_setup() {
die "At least Clang ${LLVM_MIN_SLOT} is required"
fi
fi
+ # Users should never hit this, it's purely a development convenience
+ if ver_test $(gn --version || die) -lt ${GN_MIN_VER}; then
+ die "dev-util/gn >= ${GN_MIN_VER} is required to build this Chromium"
+ fi
fi
chromium_suid_sandbox_check_kernel_config