summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory A. Pratt <anarchy@gentoo.org>2018-06-18 20:14:22 -0500
committerJory A. Pratt <anarchy@gentoo.org>2018-06-18 20:14:22 -0500
commitd786158dbadb65561d25a7c33be92959586b9da9 (patch)
treee5dc2c7ab8b3eb46534725fa0f24938c1f6bee2e /www-client
parentdev-python/logfury: new package (diff)
downloadgentoo-d786158dbadb65561d25a7c33be92959586b9da9.tar.gz
gentoo-d786158dbadb65561d25a7c33be92959586b9da9.tar.bz2
gentoo-d786158dbadb65561d25a7c33be92959586b9da9.zip
www-client/firefox: Fix llvm/clang detection for build, bug #658402 Thanks
alexander@tsoy.me for his contribution.
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/firefox-60.0.2.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/www-client/firefox/firefox-60.0.2.ebuild b/www-client/firefox/firefox-60.0.2.ebuild
index 61c634ee7586..e6ad0fecb10f 100644
--- a/www-client/firefox/firefox-60.0.2.ebuild
+++ b/www-client/firefox/firefox-60.0.2.ebuild
@@ -29,8 +29,8 @@ MOZ_HTTP_URI="https://archive.mozilla.org/pub/${PN}/releases"
MOZCONFIG_OPTIONAL_WIFI=1
-inherit check-reqs flag-o-matic toolchain-funcs eutils gnome2-utils mozconfig-v6.60 \
- pax-utils xdg-utils autotools mozlinguas-v2
+inherit check-reqs flag-o-matic toolchain-funcs eutils gnome2-utils llvm \
+ mozconfig-v6.60 pax-utils xdg-utils autotools mozlinguas-v2
DESCRIPTION="Firefox Web Browser"
HOMEPAGE="http://www.mozilla.com/firefox"
@@ -78,6 +78,10 @@ if [[ -z $GMP_PLUGIN_LIST ]]; then
GMP_PLUGIN_LIST=( gmp-gmpopenh264 gmp-widevinecdm )
fi
+llvm_check_deps() {
+ has_version "sys-devel/clang:${LLVM_SLOT}"
+}
+
pkg_setup() {
moz_pkgsetup
@@ -99,6 +103,8 @@ pkg_setup() {
fi
addpredict /proc/self/oom_score_adj
+
+ llvm_pkg_setup
}
pkg_pretend() {