summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Lin <jeffrey@icurse.nl>2019-04-01 10:05:36 -0400
committerMichał Górny <mgorny@gentoo.org>2019-04-07 10:29:08 +0200
commit00e32ad6dd819f8e640ca4f45be65a871e997b24 (patch)
treeafd889f30c2cb74793bc0f0f97759e360e17315c /www-misc/profile-sync-daemon/profile-sync-daemon-5.75.ebuild
parentapp-text/master-pdf-editor: version bump to 5.3.22 (diff)
downloadgentoo-00e32ad6dd819f8e640ca4f45be65a871e997b24.tar.gz
gentoo-00e32ad6dd819f8e640ca4f45be65a871e997b24.tar.bz2
gentoo-00e32ad6dd819f8e640ca4f45be65a871e997b24.zip
www-misc/profile-sync-daemon: bring back version 5.75
This commit partially reverts 79f41a54cc55c39e0a4ac9fba8115469f01d262e. Bug: https://bugs.gentoo.org/678658 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeffrey Lin <jeffrey@icurse.nl> Closes: https://github.com/gentoo/gentoo/pull/11473 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'www-misc/profile-sync-daemon/profile-sync-daemon-5.75.ebuild')
-rw-r--r--www-misc/profile-sync-daemon/profile-sync-daemon-5.75.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/www-misc/profile-sync-daemon/profile-sync-daemon-5.75.ebuild b/www-misc/profile-sync-daemon/profile-sync-daemon-5.75.ebuild
new file mode 100644
index 000000000000..11e5f93ac552
--- /dev/null
+++ b/www-misc/profile-sync-daemon/profile-sync-daemon-5.75.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Symlinks and syncs browser profile dirs to RAM"
+HOMEPAGE="https://wiki.archlinux.org/index.php/Profile-sync-daemon"
+SRC_URI="https://github.com/graysky2/profile-sync-daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="systemd"
+
+RDEPEND="
+ app-shells/bash
+ net-misc/rsync[xattr]
+ systemd? ( sys-apps/systemd )"
+
+PATCHES=(
+ "${FILESDIR}/openrc-path.patch"
+ "${FILESDIR}/bad-substitution-fix.patch"
+)
+
+src_install() {
+ emake DESTDIR="${ED}" COMPRESS_MAN=0 \
+ "$(usex systemd "install-systemd-all" "install-openrc-all")"
+
+ use systemd || fperms -x /etc/cron.hourly/psd-update
+}
+
+pkg_postinst() {
+ use systemd || elog "The cronjob is -x by default. You might want to set it +x."
+}