summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Lin <jeffrey@icurse.nl>2018-09-08 00:01:34 -0400
committerPatrice Clement <monsieurp@gentoo.org>2018-09-09 23:46:44 +0200
commit5fc92f703edc68e638b69c4f8ccedf4c743bf219 (patch)
treedc44e666b80c82e468f6b4bd797791dcd1db56ea /www-misc/profile-sync-daemon/profile-sync-daemon-5.75.ebuild
parentdev-python/pydiff: keyword for amd64-fbsd. (diff)
downloadgentoo-5fc92f703edc68e638b69c4f8ccedf4c743bf219.tar.gz
gentoo-5fc92f703edc68e638b69c4f8ccedf4c743bf219.tar.bz2
gentoo-5fc92f703edc68e638b69c4f8ccedf4c743bf219.zip
www-misc/profile-sync-daemon: version bump to 5.75.
Package-Manager: Portage-2.3.49, Repoman-2.3.10 Closes: https://github.com/gentoo/gentoo/pull/9807
Diffstat (limited to 'www-misc/profile-sync-daemon/profile-sync-daemon-5.75.ebuild')
-rw-r--r--www-misc/profile-sync-daemon/profile-sync-daemon-5.75.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/www-misc/profile-sync-daemon/profile-sync-daemon-5.75.ebuild b/www-misc/profile-sync-daemon/profile-sync-daemon-5.75.ebuild
new file mode 100644
index 000000000000..70b563708959
--- /dev/null
+++ b/www-misc/profile-sync-daemon/profile-sync-daemon-5.75.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Symlinks and syncs browser profile dirs to RAM"
+HOMEPAGE="https://wiki.archlinux.org/index.php/Profile-sync-daemon"
+SRC_URI="https://github.com/graysky2/profile-sync-daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="systemd zsh-completion"
+
+RDEPEND="
+ app-shells/bash
+ net-misc/rsync[xattr]
+ systemd? ( sys-apps/systemd )"
+
+PATCHES=(
+ "${FILESDIR}/openrc-path.patch"
+ "${FILESDIR}/bad-substitution-fix.patch"
+)
+
+src_install() {
+ emake DESTDIR="${ED}" \
+ install-openrc-all \
+ $(usex systemd "install-systemd" "")
+
+ if ! use zsh-completion; then
+ rm -r "${ED}/usr/share/zsh" || die
+ fi
+
+ fperms -x /etc/cron.hourly/psd-update
+}
+
+pkg_postinst() {
+ elog "The cronjob is -x by default."
+ elog "You might want to set it +x if you don't use"
+ elog "the systemd provided \"psd-resync.timer\"."
+}