summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2019-04-14 14:35:18 +0200
committerLouis Sautier <sbraz@gentoo.org>2019-04-14 15:23:09 +0200
commit88135a353597de9aa041b5e85107f821adab133a (patch)
tree876020aea9499d477b92f58794439e1401f8b1e0 /www-misc
parentgames-rpg/wastesedge: update HOMEPAGE (diff)
downloadgentoo-88135a353597de9aa041b5e85107f821adab133a.tar.gz
gentoo-88135a353597de9aa041b5e85107f821adab133a.tar.bz2
gentoo-88135a353597de9aa041b5e85107f821adab133a.zip
www-misc/urlwatch: bump to 2.17
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/urlwatch/Manifest1
-rw-r--r--www-misc/urlwatch/files/urlwatch-2.17-fix-yaml.load.patch18
-rw-r--r--www-misc/urlwatch/urlwatch-2.17.ebuild62
3 files changed, 81 insertions, 0 deletions
diff --git a/www-misc/urlwatch/Manifest b/www-misc/urlwatch/Manifest
index 4dce477bcd76..c28fb92900d1 100644
--- a/www-misc/urlwatch/Manifest
+++ b/www-misc/urlwatch/Manifest
@@ -1,3 +1,4 @@
DIST urlwatch-2.13.tar.gz 34312 BLAKE2B 6ac618d4f1f78b0a3f6d17dd2283704e8d1fc7173ce6d79fcf0f9177f48463a610a4c20d8483a4a9c22e56eca67730ef25982981f310ca8e9927e48e298a1b1d SHA512 5ca6ad3de54c2e1d63cb545ae0d213a4483ef175dad947be00994bc990d047c7aec1f3b0a8b23290672db940001a9cc31c919aa7d9c280ab4792299e2dba684c
DIST urlwatch-2.15.tar.gz 36839 BLAKE2B a474d93adb4ef95ad5c44b7cee4a077dd744caf09c84ec64b2e9f04635505a8ffd422f4ba56cb2069571b5b4b1e1f7df4b7412a716b5738388a0c55ea831e050 SHA512 3390a693656a89e75836f713249261650c03e1dc1d1819d82872d35eead7f29844502073d8674e92e97a32e44180347928e5dfada814798984d11e1ff4f0ac40
DIST urlwatch-2.16.tar.gz 42713 BLAKE2B bee95c808b8705135112646ed7bf42c6606d716f447394e69fbc3355d38597e44b3e94ac91c6c2304fadcc5eb7d35349e6d54601721319c39268583fa8c7c042 SHA512 ffa9245bc4b8631e3105b1afd4ed3c3f5585bc30cd56c7531f9c2d0e4d61e36b56db3a69d62f851bed5fba9c9c332034b1757d70b32f4a4b0607ae59ed6cf887
+DIST urlwatch-2.17.tar.gz 44178 BLAKE2B 46163b3305a50c3b5165da8f794c252aeb0a3581f16ba04cc1f0d920066accd02f7eba47718012e2ac0071f6bfa31019777a28840179a28a7fe365ae2e8f1d2c SHA512 635bca7e55641dd73447f5ec9ad429539decfaa8a1c19ab073c3bd46acfc518fa6012d855e0c37dd78654da28acf1446f580def611bcb85ae94fe13f567e3613
diff --git a/www-misc/urlwatch/files/urlwatch-2.17-fix-yaml.load.patch b/www-misc/urlwatch/files/urlwatch-2.17-fix-yaml.load.patch
new file mode 100644
index 000000000000..c8bd04ae932f
--- /dev/null
+++ b/www-misc/urlwatch/files/urlwatch-2.17-fix-yaml.load.patch
@@ -0,0 +1,18 @@
+commit d00041bacd6343cadf29c3d0a98817a7b9fda2a1
+Author: Louis Sautier <sautier.louis@gmail.com>
+Date: Sun Apr 14 14:49:24 2019 +0200
+
+ Fix YAMLLoadWarning in tests
+
+diff --git a/test/test_filters.py b/test/test_filters.py
+index 3402616..da2393b 100644
+--- a/test/test_filters.py
++++ b/test/test_filters.py
+@@ -33,6 +33,6 @@ def test_filters():
+ eq_(result, expected_result)
+
+ with open(os.path.join(os.path.dirname(__file__), 'data/filter_tests.yaml'), 'r', encoding='utf8') as fp:
+- filter_tests = yaml.load(fp)
++ filter_tests = yaml.load(fp, Loader=yaml.SafeLoader)
+ for test_name in filter_tests:
+ yield check_filter, test_name
diff --git a/www-misc/urlwatch/urlwatch-2.17.ebuild b/www-misc/urlwatch/urlwatch-2.17.ebuild
new file mode 100644
index 000000000000..240d4e646a36
--- /dev/null
+++ b/www-misc/urlwatch/urlwatch-2.17.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for monitoring webpages for updates"
+HOMEPAGE="https://thp.io/2008/urlwatch/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/minidb[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+# https://github.com/thp/urlwatch/pull/382
+PATCHES=( "${FILESDIR}/${P}-fix-yaml.load.patch" )
+
+python_test() {
+ nosetests -v test || die "tests failed with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ if ! has_version dev-python/chump; then
+ elog "Install 'dev-python/chump' to enable Pushover" \
+ "notifications support"
+ fi
+ if ! has_version dev-python/pushbullet-py; then
+ elog "Install 'dev-python/pushbullet-py' to enable" \
+ "Pushbullet notifications support"
+ fi
+ elog "HTML parsing can be improved by installing one of the following packages"
+ elog "and changing the html2text subfilter parameter:"
+ elog "dev-python/beautifulsoup:4"
+ elog "app-text/html2text"
+ elog "dev-python/html2text"
+ elog "www-client/lynx"
+ fi
+}