summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-11-23 21:24:44 -0500
committerMike Gilbert <floppym@gentoo.org>2016-11-23 21:24:44 -0500
commit0b568281d2c812f2c79c09c4548c951d4ba446f8 (patch)
tree3eaf1853a5680080c6f44a41933a868abea91f8f /www-plugins/chrome-binary-plugins/chrome-binary-plugins-56.0.2924.3_alpha.ebuild
parentwww-client/google-chrome-unstable: automated update (56.0.2924.3) (diff)
downloadgentoo-0b568281d2c812f2c79c09c4548c951d4ba446f8.tar.gz
gentoo-0b568281d2c812f2c79c09c4548c951d4ba446f8.tar.bz2
gentoo-0b568281d2c812f2c79c09c4548c951d4ba446f8.zip
www-plugins/chrome-binary-plugins: automated update (56.0.2924.3)
Package-Manager: portage-2.3.2_p8
Diffstat (limited to 'www-plugins/chrome-binary-plugins/chrome-binary-plugins-56.0.2924.3_alpha.ebuild')
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-56.0.2924.3_alpha.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-56.0.2924.3_alpha.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-56.0.2924.3_alpha.ebuild
new file mode 100644
index 000000000000..27b7eea178ed
--- /dev/null
+++ b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-56.0.2924.3_alpha.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib unpacker
+
+DESCRIPTION="Binary plugins from Google Chrome for use in Chromium"
+HOMEPAGE="https://www.google.com/chrome"
+
+case ${PV} in
+ *_alpha*)
+ SLOT="unstable"
+ CHROMEDIR="opt/google/chrome-${SLOT}"
+ MY_PV=${PV%_alpha}-1
+ ;;
+ *_beta*)
+ SLOT="beta"
+ CHROMEDIR="opt/google/chrome-${SLOT}"
+ MY_PV=${PV%_beta}-1
+ ;;
+ *)
+ SLOT="stable"
+ CHROMEDIR="opt/google/chrome"
+ MY_PV=${PV}-1
+ ;;
+esac
+
+MY_PN="google-chrome-${SLOT}"
+MY_P="${MY_PN}_${MY_PV}"
+
+SRC_URI="https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb"
+KEYWORDS="-* ~amd64"
+
+LICENSE="google-chrome"
+IUSE="+widevine"
+RESTRICT="bindist mirror strip"
+
+for x in 0 beta stable unstable; do
+ if [[ ${SLOT} != ${x} ]]; then
+ RDEPEND+=" !${CATEGORY}/${PN}:${x}"
+ fi
+done
+
+S="${WORKDIR}/${CHROMEDIR}"
+QA_PREBUILT="*"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your portage tree before reporting fetch failures."
+}
+
+src_install() {
+ local version
+
+ insinto /usr/$(get_libdir)/chromium
+ if use widevine; then
+ doins libwidevinecdm.so libwidevinecdmadapter.so
+ dosym ../chromium/libwidevinecdm.so /usr/$(get_libdir)/chromium-browser/libwidevinecdm.so
+ strings ./chrome | grep -C 1 " (version:" | tail -1 > widevine.version
+ doins widevine.version
+ fi
+}