summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2023-10-20 08:59:52 -0400
committerMike Pagano <mpagano@gentoo.org>2023-10-20 09:00:01 -0400
commit1f764adfb5e0b0f6d5ccaf53b80768ada2a36910 (patch)
treef178c7a1f5aaccd952fdbf56e2d89dd19fc938c3 /www-servers
parentdev-python/cliff: Enable py3.12 (diff)
downloadgentoo-1f764adfb5e0b0f6d5ccaf53b80768ada2a36910.tar.gz
gentoo-1f764adfb5e0b0f6d5ccaf53b80768ada2a36910.tar.bz2
gentoo-1f764adfb5e0b0f6d5ccaf53b80768ada2a36910.zip
www-servers/nginx-unit: add 1.31.1
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx-unit/Manifest1
-rw-r--r--www-servers/nginx-unit/nginx-unit-1.31.1.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/www-servers/nginx-unit/Manifest b/www-servers/nginx-unit/Manifest
index 2e6151545cbb..1f6074defe39 100644
--- a/www-servers/nginx-unit/Manifest
+++ b/www-servers/nginx-unit/Manifest
@@ -1,2 +1,3 @@
DIST nginx-unit-1.29.1.tar.gz 906654 BLAKE2B 1068a1002b05f6f9f28b19745e3c1c0f1d1def89fad8489174fd7b38ddd8c9678f27a3b105f98a17d537621cdd2cbedf9f39b4c284a7918d290287f3c324fa49 SHA512 c99cea78804ead999e62777132fe204e0f87e1b58e55b0b4a074ab8d203149c14c8faef64872a44404f8fca5bfd98d2f9e4aae2db89bebeee15f27cabbc9f247
DIST nginx-unit-1.31.0.tar.gz 905152 BLAKE2B 4b3b89318706c584fc2b80599c00bb104c1d70c14f8730b3f1142ae1b30db4cdd6516958eb0daf90031df953c0654af71a0f453a0c0c1f345241b215c207963b SHA512 ce367c81dc96b4a8d280a3e34ff8bbf1941a595c5570f9e50ffa49e1f8ac3c2e0a620be5a994a1c4c65aee7790ca227fddafba1c461fccdced83fd4c08c091e6
+DIST nginx-unit-1.31.1.tar.gz 907165 BLAKE2B 3df7258754761922dceeb66f369faec465bb2f497b692f706c6f22adb21ddf397b2aa2fee758fc89163c30517edf9cb28803193cd53bb9292573a5b21d396dc4 SHA512 28e5f1e88b9e5e21c5094f901227e193137c120e4af3f2950e113d118a301cabb17abf9f0fea8fc8893f36f6e9ae09f86bbf7a323999da34e71e42615937c57c
diff --git a/www-servers/nginx-unit/nginx-unit-1.31.1.ebuild b/www-servers/nginx-unit/nginx-unit-1.31.1.ebuild
new file mode 100644
index 000000000000..cac440e33f0d
--- /dev/null
+++ b/www-servers/nginx-unit/nginx-unit-1.31.1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit flag-o-matic python-single-r1 systemd toolchain-funcs
+
+MY_P="unit-${PV}"
+DESCRIPTION="Dynamic web and application server"
+HOMEPAGE="https://unit.nginx.org"
+SRC_URI="https://unit.nginx.org/download/${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+MY_USE="perl python ruby"
+MY_USE_PHP="php8-1 php8-2"
+IUSE="${MY_USE} ${MY_USE_PHP} perl ssl"
+REQUIRED_USE="|| ( ${IUSE} )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="perl? ( dev-lang/perl:= )
+ php8-1? ( dev-lang/php:8.1[embed] )
+ php8-2? ( dev-lang/php:8.2[embed] )
+ python? ( ${PYTHON_DEPS} )
+ ruby? (
+ dev-lang/ruby:=
+ dev-ruby/rubygems:=
+ )
+ ssl? ( dev-libs/openssl:0= )
+ virtual/libcrypt:0="
+RDEPEND="${DEPEND}
+ acct-user/nginx-unit
+ acct-group/nginx-unit"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ eapply_user
+ sed -i '/^CFLAGS/d' auto/make || die
+ default
+}
+
+src_configure() {
+ local opt=(
+ --control=unix:/run/${PN}.sock
+ --log=/var/log/${PN}
+ --modules=/usr/$(get_libdir)/${PN}
+ --pid=/run/${PN}.pid
+ --prefix=/usr
+ --state=/var/lib/${PN}
+ --user=${PN}
+ --group=${PN}
+ )
+
+ use ssl && opt+=( --openssl )
+ export AR="$(tc-getAR)"
+ export CC="$(tc-getCC)"
+ ./configure ${opt[@]} --ld-opt="${LDFLAGS}" || die "Core configuration failed"
+
+ # Modules require position-independent code
+ append-cflags $(test-flags-CC -fPIC)
+
+ for flag in ${MY_USE} ; do
+ if use ${flag} ; then
+ ./configure ${flag} || die "Module configuration failed: ${flag}"
+ fi
+ done
+
+ for flag in ${MY_USE_PHP} ; do
+ if use ${flag} ; then
+ local php_slot="/usr/$(get_libdir)/${flag/-/.}"
+ ./configure php \
+ --module=${flag} \
+ --config=${php_slot}/bin/php-config \
+ --lib-path=${php_slot}/$(get_libdir) || die "Module configuration failed: ${flag}"
+ fi
+ done
+}
+
+src_install() {
+ default
+
+ if use perl ; then
+ echo "1"
+ echo "D is ${D}"
+ emake DESTDIR="${D}/" perl-install
+ fi
+
+ rm -rf "${ED}"/usr/var
+
+ diropts -m 0770
+ keepdir /var/lib/${PN}
+ newinitd "${FILESDIR}/${PN}.initd-r2" ${PN}
+ newconfd "${FILESDIR}"/nginx-unit.confd nginx-unit
+ systemd_newunit "${FILESDIR}"/${PN}.service ${PN}.service
+}