summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-03-09 22:01:01 -0800
committerMatt Turner <mattst88@gentoo.org>2018-03-09 22:02:40 -0800
commit67e5d28160e555782c96408945c1630c8d8c4847 (patch)
treebcac03d2eb6e033eebb86c7863640f002c502c7d /x11-apps/xwininfo/xwininfo-1.1.4.ebuild
parentx11-apps/xwd: Version bump to 1.0.7 (diff)
downloadgentoo-67e5d28160e555782c96408945c1630c8d8c4847.tar.gz
gentoo-67e5d28160e555782c96408945c1630c8d8c4847.tar.bz2
gentoo-67e5d28160e555782c96408945c1630c8d8c4847.zip
x11-apps/xwininfo: Version bump to 1.1.4
Diffstat (limited to 'x11-apps/xwininfo/xwininfo-1.1.4.ebuild')
-rw-r--r--x11-apps/xwininfo/xwininfo-1.1.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-apps/xwininfo/xwininfo-1.1.4.ebuild b/x11-apps/xwininfo/xwininfo-1.1.4.ebuild
new file mode 100644
index 000000000000..4e7c0e6044cc
--- /dev/null
+++ b/x11-apps/xwininfo/xwininfo-1.1.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit xorg-2 flag-o-matic
+
+DESCRIPTION="window information utility for X"
+
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE=""
+
+RDEPEND=">=x11-libs/libxcb-1.6"
+DEPEND="${RDEPEND}
+ x11-libs/libX11
+ >=x11-proto/xproto-7.0.17"
+
+pkg_setup() {
+ # interix has a _very_ old iconv in libc, however, including
+ # iconv.h redefines those symbols to libiconv_*, which then
+ # are unresolved, as the configure check is old and dumb.
+ [[ ${CHOST} == *-interix* || ${CHOST} == *-solaris* ]] &&
+ append-libs -liconv
+}