summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-12-03 18:38:38 -0500
committerMatt Turner <mattst88@gentoo.org>2022-12-03 18:49:08 -0500
commitc213c7b1f006459158c0aa0f2f10f6e97a8e0f29 (patch)
treeadabdb0822d51bdea3e013fdd2ee967b4b622234 /x11-apps
parentx11-apps/xcursorgen: Version bump to 1.0.8 (diff)
downloadgentoo-c213c7b1f006459158c0aa0f2f10f6e97a8e0f29.tar.gz
gentoo-c213c7b1f006459158c0aa0f2f10f6e97a8e0f29.tar.bz2
gentoo-c213c7b1f006459158c0aa0f2f10f6e97a8e0f29.zip
x11-apps/xdm: Version bump to 1.1.14
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xdm/Manifest1
-rw-r--r--x11-apps/xdm/xdm-1.1.14.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/x11-apps/xdm/Manifest b/x11-apps/xdm/Manifest
index de67dcea4402..ee3a679c8d4e 100644
--- a/x11-apps/xdm/Manifest
+++ b/x11-apps/xdm/Manifest
@@ -1 +1,2 @@
DIST xdm-1.1.13.tar.xz 418404 BLAKE2B b5e1df5e0fd284b227bac5b07114b7882c34adca8c8f7878350576f865ec0675fc7f8218b5eba24e0ca75895093f9412e838a997562ec99bc8196233354bd7eb SHA512 1c7ba51dc8c6989ff6ede3a3abd06e002903609d4ebd31f06ec39fbfee3a80a690c6180f85c3ab135a0de4623261d92a191d1ca5f733cdb3bd2e7e78977b98e5
+DIST xdm-1.1.14.tar.xz 419324 BLAKE2B e1c4f1db1af670171e80b7ab759f8e477c84997a873401eb27042590eebe457b38dc7bc998c42e954012ce06c1f4c216655a9c2809a22d88e372c9f7b57e0ff0 SHA512 8ed1d2c946916c24cb4b2de9326f65629c97e53b145312c9cb9c6e4308d8b47d67d3981319fbd4feac9b3ed436b9dfb24a1c905d37d7bcf07b49c18a68c7a6e4
diff --git a/x11-apps/xdm/xdm-1.1.14.ebuild b/x11-apps/xdm/xdm-1.1.14.ebuild
new file mode 100644
index 000000000000..1fc94cdc9425
--- /dev/null
+++ b/x11-apps/xdm/xdm-1.1.14.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3 pam systemd
+
+DEFAULTVT=vt7
+
+DESCRIPTION="X.Org xdm application"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="pam systemd truetype xinerama xpm"
+
+RDEPEND="
+ x11-apps/sessreg
+ x11-apps/xconsole
+ x11-apps/xinit
+ x11-apps/xrdb
+ x11-apps/xsm
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXaw
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXt
+ virtual/libcrypt:=
+ pam? ( sys-libs/pam )
+ systemd? ( >=sys-apps/systemd-209:= )
+ truetype? (
+ x11-libs/libXrender
+ x11-libs/libXft
+ )
+ xinerama? ( x11-libs/libXinerama )
+ xpm? ( x11-libs/libXpm )
+ elibc_glibc? ( dev-libs/libbsd )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+src_prepare() {
+ sed -i -e 's:^Alias=.*$:Alias=display-manager.service:' \
+ xdm.service.in || die
+
+ # Disable XDM-AUTHORIZATION-1 (bug #445662).
+ # it causes issue with libreoffice and SDL games (bug #306223).
+ sed -i -e '/authorize/a DisplayManager*authName: MIT-MAGIC-COOKIE-1' \
+ config/xdm-config.in || die
+
+ xorg-3_src_prepare
+}
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --enable-ipv6
+ $(use_with pam)
+ $(use_with systemd systemd-daemon)
+ $(use_with truetype xft)
+ $(use_with xinerama)
+ $(use_enable xpm xpm-logos)
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ --with-default-vt=${DEFAULTVT}
+ --with-xdmconfigdir=/etc/X11/xdm
+ )
+ xorg-3_src_configure
+}
+
+src_install() {
+ xorg-3_src_install
+
+ exeinto /usr/$(get_libdir)/X11/xdm
+ doexe "${FILESDIR}"/Xsession
+
+ use pam && pamd_mimic system-local-login xdm auth account session
+
+ # Keep /var/lib/xdm. This is where authfiles are stored. See #286350.
+ keepdir /var/lib/xdm
+}