summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-10-20 17:58:23 -0700
committerMatt Turner <mattst88@gentoo.org>2017-10-20 18:00:36 -0700
commit2b5619285cf01bd620ce624d0803d799cc30e1c7 (patch)
tree68622b0b229f916a65aa5cbe6f2550cf815b177a /x11-drivers
parentdev-perl/ExtUtils-CppGuess: Fix test failures without '.' in @INC bug #615842 (diff)
downloadgentoo-2b5619285cf01bd620ce624d0803d799cc30e1c7.tar.gz
gentoo-2b5619285cf01bd620ce624d0803d799cc30e1c7.tar.bz2
gentoo-2b5619285cf01bd620ce624d0803d799cc30e1c7.zip
x11-drivers/xf86-video-intel: Version bump to 20171018
Closes: https://bugs.gentoo.org/616354
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-intel/Manifest1
-rw-r--r--x11-drivers/xf86-video-intel/xf86-video-intel-2.99.917_p20171018.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-intel/Manifest b/x11-drivers/xf86-video-intel/Manifest
index de908caf9d20..231fbf4fa3fe 100644
--- a/x11-drivers/xf86-video-intel/Manifest
+++ b/x11-drivers/xf86-video-intel/Manifest
@@ -1,2 +1,3 @@
DIST xf86-video-intel-2.99.917_p20170216.tar.xz 945436 SHA256 59819df652f605de06203add06a8e9659c15f06a4a99f88b534f1d67be07da77 SHA512 75d1f76238c4452cf6cd04df4e6cb4b0b17a33e759409f87bbfcdef80d79908e984e2adb2adfd6f98df34e49782c8f77d5ed645dd31e83045e4c687affefffbf WHIRLPOOL 23bbd37679593b186f8791098d4636c68cb9f6ca1bc5b0e8f622fdbd487fb6668ee95e4b34059eb6d59ee65fbac573fde6b71faef1217fc91964cfa2d6e73f33
DIST xf86-video-intel-2.99.917_p20170313.tar.xz 945604 SHA256 eb4e4acc88616149092238fb4fbb0b386b72c9ad15c4a9f1753af02a5d069ef0 SHA512 c3cb91c9ce843fee4ba45c41fa2c69dae4d193ce778e0988ffb0ef3c77e4da40b8879cfc7333adb97084c179502cd4b5233181b5c825de619d839cc045181740 WHIRLPOOL 323306f35a6944c6d93f31d5a3cf8f3fa4058f60c8fe3ed9ddee9c5d364a1acc5c479a59a6d4fd8dccb53e0b94bf8e142f03f4b9163a435a5318cabfb9fa40dd
+DIST xf86-video-intel-2.99.917_p20171018.tar.xz 947052 SHA256 92eebbe515d3e70bedc48a1136f2d2fb48688e317a0612d6c869f1dfa6a54601 SHA512 50aff2c6807e1d3dcc857a21501e37ab3d04598f03cde0d788aac5876feb54f5c4892ad7c34a6adda696405bfa3135a14ebd4fe41b359b34cc7ac2df1618dd88 WHIRLPOOL 042d178056aed435da824b15718226fc7475ff55511c6ac22d6e947b4ce4872863d56c45a7463de9c501af8d24cfa3f50dbe164a4b94c0d4c399d4883ef699bc
diff --git a/x11-drivers/xf86-video-intel/xf86-video-intel-2.99.917_p20171018.ebuild b/x11-drivers/xf86-video-intel/xf86-video-intel-2.99.917_p20171018.ebuild
new file mode 100644
index 000000000000..f3a9c8d55b07
--- /dev/null
+++ b/x11-drivers/xf86-video-intel/xf86-video-intel-2.99.917_p20171018.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+XORG_DRI=dri
+XORG_EAUTORECONF=yes
+inherit linux-info xorg-2 flag-o-matic
+
+DESCRIPTION="X.Org driver for Intel cards"
+
+KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="debug dri3 +sna tools +udev uxa xvmc"
+COMMIT_ID="4798e18b2b2c8b0a05dc967e6140fd9962bc1a73"
+SRC_URI="https://cgit.freedesktop.org/xorg/driver/xf86-video-intel/snapshot/${COMMIT_ID}.tar.xz -> ${P}.tar.xz"
+
+S=${WORKDIR}/${COMMIT_ID}
+
+REQUIRED_USE="
+ || ( sna uxa )
+"
+RDEPEND="
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXScrnSaver
+ >=x11-libs/pixman-0.27.1
+ >=x11-libs/libdrm-2.4.52[video_cards_intel]
+ dri3? (
+ >=x11-base/xorg-server-1.18
+ !<=media-libs/mesa-12.0.4
+ )
+ sna? (
+ >=x11-base/xorg-server-1.10
+ )
+ tools? (
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libxshmfence
+ x11-libs/libXtst
+ )
+ udev? (
+ virtual/udev
+ )
+ xvmc? (
+ x11-libs/libXvMC
+ >=x11-libs/libxcb-1.5
+ x11-libs/xcb-util
+ )
+"
+DEPEND="${RDEPEND}
+ >=x11-proto/dri2proto-2.6
+ x11-proto/dri3proto
+ x11-proto/presentproto
+ x11-proto/resourceproto"
+
+src_configure() {
+ replace-flags -Os -O2
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable debug)
+ $(use_enable dri)
+ $(use_enable dri dri3)
+ $(usex dri3 "--with-default-dri=3")
+ $(use_enable sna)
+ $(use_enable tools)
+ $(use_enable udev)
+ $(use_enable uxa)
+ $(use_enable xvmc)
+ )
+ xorg-2_src_configure
+}
+
+pkg_postinst() {
+ if linux_config_exists && \
+ kernel_is -lt 4 3 && ! linux_chkconfig_present DRM_I915_KMS; then
+ echo
+ ewarn "This driver requires KMS support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Graphics support --->"
+ ewarn " Direct Rendering Manager (XFree86 4.1.0 and higher DRI support) --->"
+ ewarn " <*> Intel 830M, 845G, 852GM, 855GM, 865G (i915 driver) --->"
+ ewarn " i915 driver"
+ ewarn " [*] Enable modesetting on intel by default"
+ echo
+ fi
+}