summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-11-14 17:33:58 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-11-14 17:33:58 +0100
commit2752ea859f10bfc0cd26793605d61592f642ee9b (patch)
tree865dccaedd0c03e64db7dca8f915f1444edbcec8 /x11-libs/gdk-pixbuf-xlib/gdk-pixbuf-xlib-2.40.2.ebuild
parentdev-lua/luasocket: drop old version (diff)
downloadgentoo-2752ea859f10bfc0cd26793605d61592f642ee9b.tar.gz
gentoo-2752ea859f10bfc0cd26793605d61592f642ee9b.tar.bz2
gentoo-2752ea859f10bfc0cd26793605d61592f642ee9b.zip
x11-libs/gdk-pixbuf-xlib: Initial commit
with kind permission from mattst88 Bug: https://bugs.gentoo.org/534330 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-libs/gdk-pixbuf-xlib/gdk-pixbuf-xlib-2.40.2.ebuild')
-rw-r--r--x11-libs/gdk-pixbuf-xlib/gdk-pixbuf-xlib-2.40.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-libs/gdk-pixbuf-xlib/gdk-pixbuf-xlib-2.40.2.ebuild b/x11-libs/gdk-pixbuf-xlib/gdk-pixbuf-xlib-2.40.2.ebuild
new file mode 100644
index 000000000000..b82aaad475a9
--- /dev/null
+++ b/x11-libs/gdk-pixbuf-xlib/gdk-pixbuf-xlib-2.40.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson multilib-minimal
+
+DESCRIPTION="Deprecated Xlib integration for GdkPixbuf"
+HOMEPAGE="https://gitlab.gnome.org/Archive/gdk-pixbuf-xlib"
+SRC_URI="https://gitlab.gnome.org/Archive/${PN}/-/archive/${PV}/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk-doc"
+
+RDEPEND="
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ >=x11-libs/gdk-pixbuf-2.42.0[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? (
+ app-text/docbook-xml-dtd:4.3
+ >=dev-util/gtk-doc-1.20
+ )
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dgtk-doc="$(multilib_native_usex gtk-doc true false)"
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+} \ No newline at end of file