summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2018-05-21 22:18:30 +0200
committerMatt Turner <mattst88@gentoo.org>2018-05-21 18:05:13 -0700
commit6057c95e193bd173984f44b6b3881d832350d2a6 (patch)
tree6ab480ad6f5b69743f242731442d0f8aa74eb5a9 /x11-libs/libast/libast-0.7-r2.ebuild
parentx11-drivers/*: Update dependencies (x11-proto/* -> x11-base/xorg-proto). (diff)
downloadgentoo-6057c95e193bd173984f44b6b3881d832350d2a6.tar.gz
gentoo-6057c95e193bd173984f44b6b3881d832350d2a6.tar.bz2
gentoo-6057c95e193bd173984f44b6b3881d832350d2a6.zip
x11-libs/*: Update dependencies (x11-proto/* -> x11-base/xorg-proto).
Diffstat (limited to 'x11-libs/libast/libast-0.7-r2.ebuild')
-rw-r--r--x11-libs/libast/libast-0.7-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-libs/libast/libast-0.7-r2.ebuild b/x11-libs/libast/libast-0.7-r2.ebuild
new file mode 100644
index 000000000000..c1751cb774ce
--- /dev/null
+++ b/x11-libs/libast/libast-0.7-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="LIBrary of Assorted Spiffy Things"
+HOMEPAGE="http://www.eterm.org/download/"
+SRC_URI="http://www.eterm.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~hppa ia64 ~mips ~ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="imlib cpu_flags_x86_mmx pcre"
+
+RDEPEND="
+ !sci-astronomy/ast
+ x11-base/xorg-proto
+ x11-libs/libXt
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ media-libs/freetype
+ imlib? ( media-libs/imlib2 )
+ pcre? ( dev-libs/libpcre )"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( README DESIGN ChangeLog )
+
+src_prepare() {
+ default
+ local myregexp="posix"
+ use pcre && myregexp="pcre"
+ econf \
+ $(use_with imlib) \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ --with-regexp="${myregexp}"
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install
+}