summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/libcryptui
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/libcryptui')
-rw-r--r--x11-libs/libcryptui/Manifest1
-rw-r--r--x11-libs/libcryptui/files/libcryptui-3.12.2-gnupg-2.1.patch11
-rw-r--r--x11-libs/libcryptui/libcryptui-3.12.2.ebuild64
-rw-r--r--x11-libs/libcryptui/metadata.xml5
4 files changed, 81 insertions, 0 deletions
diff --git a/x11-libs/libcryptui/Manifest b/x11-libs/libcryptui/Manifest
new file mode 100644
index 000000000000..dc95b5e1584a
--- /dev/null
+++ b/x11-libs/libcryptui/Manifest
@@ -0,0 +1 @@
+DIST libcryptui-3.12.2.tar.xz 1163784 SHA256 71ead1a7b496f07f6c5102ae79945dd2515b7b9342c6edefe58b47318be20866 SHA512 50ef407f0a9fe2ac8f4ab075e125fe8eabc55160b9b96a852d34e52c46be04e04b2a7c8288d2669e24865a89dc179af6bb0da8f6799e8b07fff7bc667c8eb1f0 WHIRLPOOL 0e376834c74df1492a7ffea29646a4912124b46b972dc9bdc64dd40b19e3b9c43c85eec87416f8ea0995e7d164e763bf7b5da7f66c2103df3be44f6516b8e632
diff --git a/x11-libs/libcryptui/files/libcryptui-3.12.2-gnupg-2.1.patch b/x11-libs/libcryptui/files/libcryptui-3.12.2-gnupg-2.1.patch
new file mode 100644
index 000000000000..25ad7451d311
--- /dev/null
+++ b/x11-libs/libcryptui/files/libcryptui-3.12.2-gnupg-2.1.patch
@@ -0,0 +1,11 @@
+--- configure.ac~ 2014-05-13 20:53:02.000000000 +0200
++++ configure.ac 2015-06-27 11:29:32.574106982 +0200
+@@ -95,7 +95,7 @@
+ DO_CHECK=$enableval, DO_CHECK=yes)
+
+ if test "$DO_CHECK" = "yes"; then
+- accepted_versions="1.2 1.4 2.0"
++ accepted_versions="1.2 1.4 2.0 2.1"
+ AC_PATH_PROGS(GNUPG, [gpg gpg2], no)
+ AC_DEFINE_UNQUOTED(GNUPG, "$GNUPG", [Path to gpg executable.])
+ ok="no"
diff --git a/x11-libs/libcryptui/libcryptui-3.12.2.ebuild b/x11-libs/libcryptui/libcryptui-3.12.2.ebuild
new file mode 100644
index 000000000000..2fbf7c24b900
--- /dev/null
+++ b/x11-libs/libcryptui/libcryptui-3.12.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="User interface components for OpenPGP"
+HOMEPAGE="https://wiki.gnome.org/Apps/Seahorse"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1"
+SLOT="0"
+IUSE="+introspection libnotify"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~x86-fbsd"
+
+# Pull in libnotify-0.7 because it's controlled via an automagic ifdef
+COMMON_DEPEND="
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3:3[introspection?]
+ >=dev-libs/dbus-glib-0.72
+ gnome-base/libgnome-keyring
+ x11-libs/libICE
+ x11-libs/libSM
+
+ >=app-crypt/gpgme-1
+ >=app-crypt/gnupg-1.4
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.4:= )
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+"
+DEPEND="${COMMON_DEPEND}
+ >=app-text/scrollkeeper-0.3
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# Before 3.1.4, libcryptui was part of seahorse
+RDEPEND="${COMMON_DEPEND}
+ !<app-crypt/seahorse-3.1.4
+"
+
+src_prepare() {
+ # Support GnuPG 2.1, https://bugzilla.gnome.org/show_bug.cgi?id=745843
+ epatch "${FILESDIR}"/${PN}-3.12.2-gnupg-2.1.patch
+
+ # FIXME: Do not mess with CFLAGS with USE="debug"
+ sed -e '/CFLAGS="$CFLAGS -g -O0/d' \
+ -e 's/-Werror//' \
+ -i configure.ac configure || die "sed failed"
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --disable-update-mime-database \
+ $(use_enable introspection) \
+ $(use_enable libnotify)
+}
diff --git a/x11-libs/libcryptui/metadata.xml b/x11-libs/libcryptui/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/x11-libs/libcryptui/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>