summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2024-04-20 16:46:24 +0300
committerMart Raudsepp <leio@gentoo.org>2024-04-20 17:36:16 +0300
commita55584d6e3620cf4df781c2f96adcb32d1c88335 (patch)
tree14ed50c8fbcbf59ba134d37182d40eab88a9c451 /x11-libs/pango
parentdev-python/PyQt-builder: add 1.16.1 (diff)
downloadgentoo-a55584d6e3620cf4df781c2f96adcb32d1c88335.tar.gz
gentoo-a55584d6e3620cf4df781c2f96adcb32d1c88335.tar.bz2
gentoo-a55584d6e3620cf4df781c2f96adcb32d1c88335.zip
x11-libs/pango: add 1.52.2
Also drop unnecessary subslot dep operators. Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'x11-libs/pango')
-rw-r--r--x11-libs/pango/Manifest1
-rw-r--r--x11-libs/pango/pango-1.52.2.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/x11-libs/pango/Manifest b/x11-libs/pango/Manifest
index 3b418ca35a66..602cb9a92e9c 100644
--- a/x11-libs/pango/Manifest
+++ b/x11-libs/pango/Manifest
@@ -2,3 +2,4 @@ DIST pango-1.42.4-patchset.tar.xz 6040 BLAKE2B ec3f1a6a4de30e0864e7f0bf0950cb7a7
DIST pango-1.42.4.tar.xz 833876 BLAKE2B 7de1094a29750b9e59ea1e5c92644fa5d6b835828d027963a53cce3f204ee1ea0042ec492e209de9136f05ca131ccda959bc477d4f6e9c72e5f620ddf4235f26 SHA512 993e97f647eba0c5ed90bcfcb8228bf67fa3f20b1f4331e4e40a30788d7c3ac55eee1209471bf21df125cb8fc6121acc8062a9da2f8a7d6cbe8e9ad13a9320dc
DIST pango-1.51.0.tar.xz 1942044 BLAKE2B d7d343d5fb005b92dc70fc6f65c62d1d22cc81887185612d276e63614e622272117b64051f46aa1ae0348d4ccfbed0a473f9482703d51d5da7e81d1851b49071 SHA512 a427e93cdc00bf4bc97da2e1897363a53688886f112c8732684cc66c67b16fe82a84cf581ffa6c18a206e8e37bd54db4104856fdab8afa5a50a8bc0470e5d282
DIST pango-1.52.1.tar.xz 1956856 BLAKE2B 0b7f58f3d74bd37df285f3fbf14d2d2d776fbcf773568d63f12f26976d2ff505c19616fcee11562933df2594762e9ca30fe96a1d02dcd174381b976d63c68ac1 SHA512 7cddbd61afc3c98ffd09ea08c5d7613e454b6705f72304cb9b3578865b6bda70ca20f98605dea73f2cbca5e264217c8d79e4539e9eb36b8775d5d2a4f769cf32
+DIST pango-1.52.2.tar.xz 1963588 BLAKE2B 9367703addcc6805fc14f0c0184d9d1b4093b8947fea9d260c54eb6c86ce56a0d6cfe35c3d6340eaa5d96fb84f0a94c5979ae308bfa79f02e4ce25c4c093556e SHA512 6b3d762d133e7c900c6dfa85f43c950699930f6149cb3c90bf0e787f1b5a126a0b90220b90e649f84e4c244e44c46d4b575d5d7afeb305232c333712effc0981
diff --git a/x11-libs/pango/pango-1.52.2.ebuild b/x11-libs/pango/pango-1.52.2.ebuild
new file mode 100644
index 000000000000..08faaa35ef89
--- /dev/null
+++ b/x11-libs/pango/pango-1.52.2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic gnome2-utils meson-multilib xdg
+
+DESCRIPTION="Internationalized text layout and rendering library"
+HOMEPAGE="https://www.pango.org/ https://gitlab.gnome.org/GNOME/pango"
+SRC_URI="http://ftp.gnome.org/pub/GNOME/sources/pango/$(ver_cut 1-2)/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+IUSE="debug +introspection sysprof test X"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.62.2:2[${MULTILIB_USEDEP}]
+ >=dev-libs/fribidi-1.0.6[${MULTILIB_USEDEP}]
+ >=media-libs/harfbuzz-2.6.0:=[glib(+),introspection?,truetype(+),${MULTILIB_USEDEP}]
+ >=media-libs/fontconfig-2.13.0:1.0[${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.12.10[X?,${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.5.0.1:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXft-2.3.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4[${MULTILIB_USEDEP}] )
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="
+ dev-util/glib-utils
+ sys-apps/help2man
+ virtual/pkgconfig
+ test? ( media-fonts/cantarell )
+"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+ gnome2_environment_reset
+}
+
+multilib_src_configure() {
+ if use debug; then
+ append-cflags -DPANGO_ENABLE_DEBUG
+ else
+ append-cflags -DG_DISABLE_CAST_CHECKS
+ fi
+
+ local emesonargs=(
+ # Never use gi-docgen subproject
+ --wrap-mode nofallback
+
+ -Dgtk_doc=false # we ship pregenerated docs
+ $(meson_native_use_feature introspection)
+ -Dinstall-tests=false
+ -Dfontconfig=enabled
+ $(meson_feature sysprof)
+ -Dlibthai=disabled
+ -Dcairo=enabled
+ $(meson_feature X xft)
+ -Dfreetype=enabled
+ )
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ insinto /usr/share/gtk-doc/html
+ # This will install PangoXft API docs regardless of USE=-X, but this is intentional
+ doins -r "${S}"/docs/Pango*
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if has_version 'media-libs/freetype[-harfbuzz]' ; then
+ ewarn "media-libs/freetype is installed without harfbuzz support. This may"
+ ewarn "lead to minor font rendering problems, see bug 712374."
+ fi
+}