summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/qwt/qwt-5.2.3-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/qwt/qwt-5.2.3-r2.ebuild')
-rw-r--r--x11-libs/qwt/qwt-5.2.3-r2.ebuild102
1 files changed, 102 insertions, 0 deletions
diff --git a/x11-libs/qwt/qwt-5.2.3-r2.ebuild b/x11-libs/qwt/qwt-5.2.3-r2.ebuild
new file mode 100644
index 000000000000..24e14e42d1d7
--- /dev/null
+++ b/x11-libs/qwt/qwt-5.2.3-r2.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multibuild qt4-r2
+
+DESCRIPTION="2D plotting library for Qt4"
+HOMEPAGE="http://qwt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="qwt"
+KEYWORDS="~alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-macos"
+SLOT="5"
+IUSE="doc examples static-libs svg"
+
+DEPEND="
+ dev-qt/designer:4
+ dev-qt/qtgui:4
+ doc? ( !<media-libs/coin-3.1.3[doc] )
+ svg? ( dev-qt/qtsvg:4 )"
+RDEPEND="${DEPEND}"
+
+DOCS="CHANGES README"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-install_qt.patch
+ sed -e "/QwtVersion/s:5.2.2.:${PV}:g" -i ${PN}.prf || die
+
+ cat > qwtconfig.pri <<-EOF
+ target.path = "${EPREFIX}/usr/$(get_libdir)"
+ headers.path = "${EPREFIX}/usr/include/qwt5"
+ doc.path = "${EPREFIX}/usr/share/doc/${PF}"
+ CONFIG += qt warn_on thread release
+ CONFIG += QwtPlot QwtWidgets QwtDesigner
+ VERSION = ${PV}
+ QWT_VERSION = ${PV/_*}
+ QWT_INSTALL_PLUGINS = "${EPREFIX}/usr/$(get_libdir)/qt4/plugins/designer"
+ QWT_INSTALL_FEATURES = "${EPREFIX}/usr/share/qt4/mkspecs/features"
+ EOF
+ sed -i -e 's/headers doc/headers/' src/src.pro || die
+ use svg && echo >> qwtconfig.pri "CONFIG += QwtSVGItem"
+
+ MULTIBUILD_VARIANTS=( )
+ use static-libs && MULTIBUILD_VARIANTS+=( static )
+ MULTIBUILD_VARIANTS+=( shared )
+
+ qt4-r2_src_prepare
+
+ preparation() {
+ cp -rf "${S}" "${BUILD_DIR}" || die
+ [[ ${MULTIBUILD_VARIANT} == shared ]] && \
+ echo "CONFIG += QwtDll" >> "${BUILD_DIR}"/qwtconfig.pri
+ }
+
+ multibuild_foreach_variant preparation
+}
+
+src_configure() {
+ multibuild_parallel_foreach_variant run_in_build_dir eqmake4 ${PN}.pro
+}
+
+src_compile() {
+ multibuild_foreach_variant run_in_build_dir qt4-r2_src_compile
+}
+
+src_test() {
+ testing() {
+ cd examples || die
+ eqmake4 examples.pro
+ emake
+ }
+ multibuild_foreach_variant run_in_build_dir testing
+}
+
+src_install () {
+ multibuild_foreach_variant run_in_build_dir qt4-r2_src_install
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ rm doc/man/*/*license* || die
+ rm -f doc/man/*/{_,deprecated}* || die
+ doman doc/man/*/*
+ doins -r doc/html
+ fi
+ if use examples; then
+ # don't build examples - fix the qt files to build once installed
+ cat > examples/examples.pri <<-EOF
+ include( qwtconfig.pri )
+ TEMPLATE = app
+ MOC_DIR = moc
+ INCLUDEPATH += "${EPREFIX}/usr/include/qwt5"
+ DEPENDPATH += "${EPREFIX}/usr/include/qwt5"
+ LIBS += -lqwt
+ EOF
+ sed -i -e 's:../qwtconfig:qwtconfig:' examples/examples.pro || die
+ cp *.pri examples/ || die
+ insinto /usr/share/${PN}5
+ doins -r examples
+ fi
+}