summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-08-04 13:28:52 +0300
committerMart Raudsepp <leio@gentoo.org>2019-08-04 13:29:07 +0300
commit7594a51367ad57aad6162a26892faeaa685db177 (patch)
tree7d1747af512902ec0a6655302fc995506eb10613 /x11-libs/vte
parentdev-libs/libgudev: fix LICENSE (diff)
downloadgentoo-7594a51367ad57aad6162a26892faeaa685db177.tar.gz
gentoo-7594a51367ad57aad6162a26892faeaa685db177.tar.bz2
gentoo-7594a51367ad57aad6162a26892faeaa685db177.zip
x11-libs/vte: fix vala:0.44 compatibility properly
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'x11-libs/vte')
-rw-r--r--x11-libs/vte/files/0.54.4-vala-0.44-compat.patch29
-rw-r--r--x11-libs/vte/vte-0.48.4.ebuild3
-rw-r--r--x11-libs/vte/vte-0.54.4.ebuild6
3 files changed, 36 insertions, 2 deletions
diff --git a/x11-libs/vte/files/0.54.4-vala-0.44-compat.patch b/x11-libs/vte/files/0.54.4-vala-0.44-compat.patch
new file mode 100644
index 000000000000..5da32bea838a
--- /dev/null
+++ b/x11-libs/vte/files/0.54.4-vala-0.44-compat.patch
@@ -0,0 +1,29 @@
+From 53690d5cee51bdb7c3f7680d3c22b316b1086f2c Mon Sep 17 00:00:00 2001
+From: Rico Tzschichholz <ricotz@ubuntu.com>
+Date: Sat, 1 Dec 2018 19:04:59 +0100
+Subject: [PATCH] vala: Fix build with vala 0.43+ git master due to empty
+ struct definition
+
+This should get a proper refactoring as the FIXME suggests.
+
+See https://gitlab.gnome.org/GNOME/vte/issues/76
+---
+ bindings/vala/app.vala | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/bindings/vala/app.vala b/bindings/vala/app.vala
+index 8663d63c..a534e76b 100644
+--- a/bindings/vala/app.vala
++++ b/bindings/vala/app.vala
+@@ -819,6 +819,8 @@ class App : Gtk.Application
+
+ public struct Options
+ {
++ //FIXME Merge this struct into App class
++ public int dummy;
+ public static bool audible = false;
+ public static string? command = null;
+ private static string? cjk_ambiguous_width_string = null;
+--
+2.20.1
+
diff --git a/x11-libs/vte/vte-0.48.4.ebuild b/x11-libs/vte/vte-0.48.4.ebuild
index 23c0c8fdfbdb..779dabd7b871 100644
--- a/x11-libs/vte/vte-0.48.4.ebuild
+++ b/x11-libs/vte/vte-0.48.4.ebuild
@@ -52,6 +52,9 @@ src_prepare() {
eapply "${WORKDIR}"/${P}-command-notify.patch
fi
+ # Fix bindings test compilation with vala:0.44 and newer - https://gitlab.gnome.org/GNOME/vte/issues/76
+ eapply "${FILESDIR}"/0.54.4-vala-0.44-compat.patch
+
use vala && vala_src_prepare
# build fails because of -Werror with gcc-5.x
diff --git a/x11-libs/vte/vte-0.54.4.ebuild b/x11-libs/vte/vte-0.54.4.ebuild
index 54d358839290..e11d9d2ec6bb 100644
--- a/x11-libs/vte/vte-0.54.4.ebuild
+++ b/x11-libs/vte/vte-0.54.4.ebuild
@@ -3,8 +3,7 @@
EAPI="6"
VALA_USE_DEPEND="vapigen"
-VALA_MIN_API_VERSION="0.36"
-VALA_MAX_API_VERSION="0.42"
+VALA_MIN_API_VERSION="0.32"
inherit gnome2 vala
@@ -53,6 +52,9 @@ src_prepare() {
eapply "${WORKDIR}"/${PN}-0.54.1-command-notify.patch
fi
+ # Fix bindings test compilation with vala:0.44 and newer - https://gitlab.gnome.org/GNOME/vte/issues/76
+ eapply "${FILESDIR}"/${PV}-vala-0.44-compat.patch
+
use vala && vala_src_prepare
# build fails because of -Werror with gcc-5.x