summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-07-20 12:36:27 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-07-20 12:59:20 -0400
commit94db238da7e1e4e606e24cb84579b3f2bb3e6fbf (patch)
tree3cbac8d7a75038be2a7d15665613c54bcafcbf0b /x11-libs
parentx11-wm/sawfish: new version 1.11.90. (diff)
downloadgentoo-94db238da7e1e4e606e24cb84579b3f2bb3e6fbf.tar.gz
gentoo-94db238da7e1e4e606e24cb84579b3f2bb3e6fbf.tar.bz2
gentoo-94db238da7e1e4e606e24cb84579b3f2bb3e6fbf.zip
x11-libs/rep-gtk: new version 0.90.8.3 updating the ebuild to EAPI=6.
Gentoo-Bug: 493110 Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/rep-gtk/Manifest1
-rw-r--r--x11-libs/rep-gtk/rep-gtk-0.90.8.3.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/x11-libs/rep-gtk/Manifest b/x11-libs/rep-gtk/Manifest
index 0b9be6471b1b..af3c3a77f669 100644
--- a/x11-libs/rep-gtk/Manifest
+++ b/x11-libs/rep-gtk/Manifest
@@ -1 +1,2 @@
DIST rep-gtk-0.90.8.1.tar.xz 251652 SHA256 aebb2ae356cb11a2a5a6516703f1b5c6d1d71c48715bc340c13db98b9bd1a650 SHA512 033c148b34591672f29b0a1636b4c962ff82423f627243db07746899bfbf0ccd479322743d0822903bf954cdb3bae662ef7b2f8064cbe2741c5e8cf886e56d1b WHIRLPOOL c76745c3fef4d839b9834940181c5618ad038927f597e866821ee9faf1e6256053d6f60e94776d2a7afb46f9892a1cfcb9b9da229cdd117b1b788922e90771a4
+DIST rep-gtk_0.90.8.3.tar.xz 120616 SHA256 a96575db45794eefd0564172967a38ef2d7fec3ae2644c478e9f7d54b99ff341 SHA512 d33de562c94731c0ce0fbca574952b9f36c2f2cb084783976486c8751daba5de0d20bc781a06ebd2005e541bbbec3f984453ef65ba6233bb7acfefa31b1acaac WHIRLPOOL 23144629026650331495cbd1c29df24282e0ea27194dd02efde5d7c61fe70159c0f31bff227366acd965eacd7489ebe4d4b0e093d4b823b77dc56390a903ce09
diff --git a/x11-libs/rep-gtk/rep-gtk-0.90.8.3.ebuild b/x11-libs/rep-gtk/rep-gtk-0.90.8.3.ebuild
new file mode 100644
index 000000000000..85e30c1fb08c
--- /dev/null
+++ b/x11-libs/rep-gtk/rep-gtk-0.90.8.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils
+
+MY_P="${PN}_${PV}"
+DESCRIPTION="GTK+/libglade/GNOME bindings for the librep Lisp environment"
+HOMEPAGE="http://sawfish.wikia.com/wiki/Main_Page"
+SRC_URI="http://download.tuxfamily.org/librep/${PN}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="gtk-2.0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+RDEPEND=">=dev-libs/librep-0.90.5
+ >=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.24.0:2
+ >=x11-libs/gdk-pixbuf-2.23:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-arch/xz-utils"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS ChangeLog README README.gtk-defs README.guile-gtk TODO )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --disable-static
+}
+
+src_install() {
+ default
+ use examples && dodoc -r examples
+ find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
+}