summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/bbdate
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/bbdate')
-rw-r--r--x11-misc/bbdate/Manifest1
-rw-r--r--x11-misc/bbdate/bbdate-0.2.4-r1.ebuild34
-rw-r--r--x11-misc/bbdate/files/bbdate-0.2.4-as-needed.patch21
-rw-r--r--x11-misc/bbdate/metadata.xml11
4 files changed, 67 insertions, 0 deletions
diff --git a/x11-misc/bbdate/Manifest b/x11-misc/bbdate/Manifest
new file mode 100644
index 000000000000..43e85e9026dc
--- /dev/null
+++ b/x11-misc/bbdate/Manifest
@@ -0,0 +1 @@
+DIST bbdate-0.2.4.tar.gz 60644 SHA256 a7957e8b8aa27b7d15d05ba19011311693d4ffd3bb53f023d1f2346f142bb802 SHA512 90c51249a6ad0b90aea640b1f94cee4e9feb3ca46e4407ab3be645f92a32e7c3f1879c58a236c487dd7bfb24aae1f6a03da0a535c9218fbcbcdbd1e6f043d041 WHIRLPOOL 29f3c9879769248f283969e17084e04262438fdaeb1a2fcb0a8132394796d775a4fc14362c9d127987d81b48d2e50ea0d928d88ab7d44eace19bd8b96bdef75d
diff --git a/x11-misc/bbdate/bbdate-0.2.4-r1.ebuild b/x11-misc/bbdate/bbdate-0.2.4-r1.ebuild
new file mode 100644
index 000000000000..67068033465c
--- /dev/null
+++ b/x11-misc/bbdate/bbdate-0.2.4-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils autotools
+
+DESCRIPTION="blackbox date display"
+HOMEPAGE="http://sourceforge.net/projects/bbtools"
+SRC_URI="mirror://sourceforge/bbtools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86 ~x86-fbsd"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ sed -i \
+ -e 's|-helvetica-|-*-|g' \
+ resource.cc data/${PN}.{nobb,style} || die
+ eautoreconf
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README AUTHORS BUGS INSTALL ChangeLog TODO
+
+ # since multiple bbtools packages provide this file, install
+ # it in /usr/share/doc/${PF}
+ mv "${D}"/usr/share/bbtools/bbtoolsrc.in \
+ "${D}"/usr/share/doc/${PF}/bbtoolsrc.example
+}
diff --git a/x11-misc/bbdate/files/bbdate-0.2.4-as-needed.patch b/x11-misc/bbdate/files/bbdate-0.2.4-as-needed.patch
new file mode 100644
index 000000000000..38767a76443b
--- /dev/null
+++ b/x11-misc/bbdate/files/bbdate-0.2.4-as-needed.patch
@@ -0,0 +1,21 @@
+Reason: Correct lib and ldflags ordering, fixes --as-needed.
+Upstream: No.
+--- bbdate-0.2.4/configure.in
++++ bbdate-0.2.4/configure.in
+@@ -47,12 +47,13 @@
+
+ CFLAGS="$CFLAGS $X_CFLAGS"
+ CXXFLAGS="$CXXFLAGS $X_CFLAGS"
+-LDFLAGS="$LDFLAGS $X_LIBS $X_PRE_LIBS"
++LDFLAGS="$LDFLAGS"
++LIBS="$X_LIBS $X_PRE_LIBS"
+ dnl Checks for X libraries.
+-AC_CHECK_LIB(X11, XOpenDisplay, LDFLAGS="$LDFLAGS -lX11",
++AC_CHECK_LIB(X11, XOpenDisplay, LIBS="$LIBS -lX11",
+ AC_MSG_ERROR(XOpenDisplay not found in -lX11))
+
+-LDFLAGS="$LDFLAGS $X_EXTRA_LIBS"
++LIBS="$LIBS $X_EXTRA_LIBS"
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
diff --git a/x11-misc/bbdate/metadata.xml b/x11-misc/bbdate/metadata.xml
new file mode 100644
index 000000000000..7771645ed3d5
--- /dev/null
+++ b/x11-misc/bbdate/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>A data display for Blackbox.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">bbtools</remote-id>
+ </upstream>
+</pkgmetadata>