summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-10-11 14:49:06 +0200
committerJeroen Roovers <jer@gentoo.org>2018-10-11 14:49:36 +0200
commit52d5b5ba3a2b02abd3014b5108d5d4619e1f6b16 (patch)
tree10f602ffa1d33933d691ac38c02f2ebc4b86ac65 /x11-misc/i3lock
parentapp-vim/gentoo-syntax-20180821-r0: alpha stable (diff)
downloadgentoo-52d5b5ba3a2b02abd3014b5108d5d4619e1f6b16.tar.gz
gentoo-52d5b5ba3a2b02abd3014b5108d5d4619e1f6b16.tar.bz2
gentoo-52d5b5ba3a2b02abd3014b5108d5d4619e1f6b16.zip
x11-misc/i3lock: Version 2.11
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/i3lock')
-rw-r--r--x11-misc/i3lock/Manifest1
-rw-r--r--x11-misc/i3lock/files/i3lock-2.11-version.patch12
-rw-r--r--x11-misc/i3lock/i3lock-2.11.ebuild47
3 files changed, 60 insertions, 0 deletions
diff --git a/x11-misc/i3lock/Manifest b/x11-misc/i3lock/Manifest
index dc4ef9355f94..8f83a8483856 100644
--- a/x11-misc/i3lock/Manifest
+++ b/x11-misc/i3lock/Manifest
@@ -1 +1,2 @@
DIST i3lock-2.10.tar.bz2 23171 BLAKE2B 1c1d0f8e3a85dcebe4a9ee181e399a4ff447ececfbdf5f9488df849316e47233118b7436c269a986fed4e907e6162f3758c8bdad2d20ac156e95a8be185a744c SHA512 ea865b202668212b58d0b97d0263171847e1bd0c529e2fd3d26c15ef253861b9a8357ff2efaa6a4f342c4d0d1ab03bc00f95f4d4008760ec8e0767ac29195517
+DIST i3lock-2.11.tar.bz2 145308 BLAKE2B adacff63670237b945b54ba9709725013f8cfb5bdaf48e6c2cfbc0b035161e44f30393443f9326e3d0635407d1451267d9be8898582a76b3f989660ddcda2440 SHA512 c00741a66fdb5477a4b7e993d173f98fe95f0254fa74c50f83ddf8078a477d26a9fab126fbe31b509df2dbd35ed5ec64b95475621b8babf6f6c0f6db38160c8a
diff --git a/x11-misc/i3lock/files/i3lock-2.11-version.patch b/x11-misc/i3lock/files/i3lock-2.11-version.patch
new file mode 100644
index 000000000000..df133cb91cdb
--- /dev/null
+++ b/x11-misc/i3lock/files/i3lock-2.11-version.patch
@@ -0,0 +1,12 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -2,7 +2,7 @@
+ # Run autoreconf -fi to generate a configure script from this file.
+
+ AC_PREREQ([2.69])
+-AC_INIT([i3lock], [2.10], [https://github.com/i3/i3lock/issues])
++AC_INIT([i3lock], [2.11], [https://github.com/i3/i3lock/issues])
+ # For AX_EXTEND_SRCDIR
+ AX_ENABLE_BUILDDIR
+ AM_INIT_AUTOMAKE([foreign subdir-objects -Wall no-dist-gzip dist-bzip2])
+
diff --git a/x11-misc/i3lock/i3lock-2.11.ebuild b/x11-misc/i3lock/i3lock-2.11.ebuild
new file mode 100644
index 000000000000..54d9140d574c
--- /dev/null
+++ b/x11-misc/i3lock/i3lock-2.11.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Simple screen locker"
+HOMEPAGE="https://i3wm.org/i3lock/"
+SRC_URI="https://i3wm.org/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=x11-libs/libxkbcommon-0.5.0[X]
+ dev-libs/libev
+ virtual/pam
+ x11-libs/cairo[xcb]
+ x11-libs/libxcb[xkb]
+ x11-libs/xcb-util
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+DOCS=( CHANGELOG README.md )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.11-version.patch
+)
+
+src_prepare() {
+ default
+
+ echo ${PV} > I3LOCK_VERSION
+
+ sed -i -e 's:login:system-auth:' ${PN}.pam || die
+
+ eautoreconf
+
+ tc-export CC
+}
+
+src_install() {
+ default
+ doman ${PN}.1
+}