summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-09-10 23:00:59 +0200
committerJeroen Roovers <jer@gentoo.org>2017-09-10 23:17:59 +0200
commitdf5c0e245253b32cf09c681bee36f0fa6bc28378 (patch)
tree230ab04d99d99ea3b1861e8e2a530258c12e980e /x11-misc/sent/sent-1.ebuild
parentdev-libs/libclc: adjust slot dependency (diff)
downloadgentoo-df5c0e245253b32cf09c681bee36f0fa6bc28378.tar.gz
gentoo-df5c0e245253b32cf09c681bee36f0fa6bc28378.tar.bz2
gentoo-df5c0e245253b32cf09c681bee36f0fa6bc28378.zip
x11-misc/sent: Version bump.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'x11-misc/sent/sent-1.ebuild')
-rw-r--r--x11-misc/sent/sent-1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/sent/sent-1.ebuild b/x11-misc/sent/sent-1.ebuild
new file mode 100644
index 000000000000..cf97bb7c5a01
--- /dev/null
+++ b/x11-misc/sent/sent-1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="Simple plaintext presentation tool"
+HOMEPAGE="https://tools.suckless.org/sent/"
+SRC_URI="https://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ media-libs/fontconfig
+ x11-libs/libX11
+ x11-libs/libXft
+"
+RDEPEND="
+ ${DEPEND}
+ media-gfx/farbfeld
+"
+S=${WORKDIR}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's|^ @| |g' \
+ -e 's|@${CC}|$(CC)|g' \
+ -e '/^ echo/d' \
+ Makefile || die
+
+ restore_config config.def.h
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+}