summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/wininfo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/wininfo')
-rw-r--r--x11-misc/wininfo/Manifest1
-rw-r--r--x11-misc/wininfo/files/wininfo-0.7-desktop-entry.patch14
-rw-r--r--x11-misc/wininfo/metadata.xml5
-rw-r--r--x11-misc/wininfo/wininfo-0.7.ebuild31
4 files changed, 51 insertions, 0 deletions
diff --git a/x11-misc/wininfo/Manifest b/x11-misc/wininfo/Manifest
new file mode 100644
index 000000000000..48f9877291ea
--- /dev/null
+++ b/x11-misc/wininfo/Manifest
@@ -0,0 +1 @@
+DIST wininfo-0.7.tar.gz 479409 RMD160 de71cf043e126f4bb0a10ecc3e323cd5bc588679 SHA1 b9d3b541cff1a05646678aa1608e079298c59c2a SHA256 8bb02068b183c684b04b4a5dc46dee041aa224c5843348cd16f2b53503b41833
diff --git a/x11-misc/wininfo/files/wininfo-0.7-desktop-entry.patch b/x11-misc/wininfo/files/wininfo-0.7-desktop-entry.patch
new file mode 100644
index 000000000000..478fb2e83481
--- /dev/null
+++ b/x11-misc/wininfo/files/wininfo-0.7-desktop-entry.patch
@@ -0,0 +1,14 @@
+diff -ur wininfo-0.7.orig/docs/xdg-wininfo.desktop wininfo-0.7/docs/xdg-wininfo.desktop
+--- wininfo-0.7.orig/docs/xdg-wininfo.desktop 2004-08-26 07:15:35.000000000 +0300
++++ wininfo-0.7/docs/xdg-wininfo.desktop 2008-02-02 14:46:55.000000000 +0200
+@@ -1,9 +1,8 @@
+ [Desktop Entry]
+-Encoding=UTF-8
+ Comment=A window information utility for X
+ Exec=wininfo
+ Name=X Window Information
+ GenericName=X Debugging Tool
+ Terminal=false
+ Type=Application
+-Categories=Application;Development;
++Categories=Development;GTK;
diff --git a/x11-misc/wininfo/metadata.xml b/x11-misc/wininfo/metadata.xml
new file mode 100644
index 000000000000..2518313f5241
--- /dev/null
+++ b/x11-misc/wininfo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>
diff --git a/x11-misc/wininfo/wininfo-0.7.ebuild b/x11-misc/wininfo/wininfo-0.7.ebuild
new file mode 100644
index 000000000000..b990bc66abbf
--- /dev/null
+++ b/x11-misc/wininfo/wininfo-0.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="An X app that follows your pointer providing information about the windows below"
+HOMEPAGE="http://freedesktop.org/Software/wininfo"
+SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXres
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-desktop-entry.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README
+}