summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xbatt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xbatt')
-rw-r--r--x11-misc/xbatt/Manifest2
-rw-r--r--x11-misc/xbatt/files/xbatt-1.2.1-implicits.patch14
-rw-r--r--x11-misc/xbatt/metadata.xml5
-rw-r--r--x11-misc/xbatt/xbatt-1.2.1-r1.ebuild42
-rw-r--r--x11-misc/xbatt/xbatt-1.3_rc1.ebuild45
5 files changed, 108 insertions, 0 deletions
diff --git a/x11-misc/xbatt/Manifest b/x11-misc/xbatt/Manifest
new file mode 100644
index 000000000000..dcd0d00833ce
--- /dev/null
+++ b/x11-misc/xbatt/Manifest
@@ -0,0 +1,2 @@
+DIST xbatt-1.2.1.tar.gz 12779 SHA256 6c184c23e2be2b4934ccfcae39b158d5bab81e9f602a412bdbce57b436fd3b66 SHA512 db96f89e3abecd23532305069806ac094d5a31797f6f730d0f0d5345ac3f339286a5e3bcfc73d42a44a666bcbc768c955b9c3d8ca2fd28bd8239dfa109fe7020 WHIRLPOOL ba4268f33202b576b39837894c71172660d4103f07e11081d3e215828f87738067ac1798c50469342d29baa7d6523e7ff30aba91b5f7a57ebac5c48cce3b2506
+DIST xbatt-1.3pr1.tar.gz 14412 SHA256 aa41269247dd818ce1f92a16af3ea286ac34b395cb39daa1196fca5adfb5ed4b SHA512 f6022a2d464e22a31c8246f20c4dcab2be381ec63a02fb9ac1d3e28dc9bdf26a949735b2eba800941f5dfde371913ea7a560413191197c44a0c156a58a60d41d WHIRLPOOL abf6148df8ae8be6ea328f41b801c28e675959b6b0ec9a4b684fa7ce6c1b3b757209176203ac0bb318eff0dfc246b939853227fb02862684f983b60e8aa7652b
diff --git a/x11-misc/xbatt/files/xbatt-1.2.1-implicits.patch b/x11-misc/xbatt/files/xbatt-1.2.1-implicits.patch
new file mode 100644
index 000000000000..d86e42ef3fc8
--- /dev/null
+++ b/x11-misc/xbatt/files/xbatt-1.2.1-implicits.patch
@@ -0,0 +1,14 @@
+Fix implicit functions declarations
+
+--- xbatt.c
++++ xbatt.c
+@@ -47,6 +47,9 @@
+ #include <time.h>
+ #include <sys/file.h>
+ #include <sys/ioctl.h>
++#include <unistd.h>
++#include <stdlib.h>
++#include <X11/IntrinsicP.h>
+ #include <X11/StringDefs.h>
+ #include <X11/Intrinsic.h>
+ #include <X11/Shell.h>
diff --git a/x11-misc/xbatt/metadata.xml b/x11-misc/xbatt/metadata.xml
new file mode 100644
index 000000000000..2518313f5241
--- /dev/null
+++ b/x11-misc/xbatt/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>
diff --git a/x11-misc/xbatt/xbatt-1.2.1-r1.ebuild b/x11-misc/xbatt/xbatt-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..df07cf26f61c
--- /dev/null
+++ b/x11-misc/xbatt/xbatt-1.2.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Notebook battery indicator for X"
+HOMEPAGE="http://www.clave.gr.jp/~eto/xbatt/"
+SRC_URI="http://www.clave.gr.jp/~eto/xbatt/${P}.tar.gz"
+
+LICENSE="xbatt"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXaw
+ x11-libs/libXext
+ x11-libs/libxkbfile
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-misc/imake"
+
+src_prepare(){
+ epatch "${FILESDIR}"/${P}-implicits.patch
+}
+
+src_compile() {
+ xmkmf || die
+ emake xbatt CDEBUGFLAGS="${CFLAGS}" CC="$(tc-getCC)" \
+ EXTRA_LDOPTIONS="${LDFLAGS}" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README* || die
+}
diff --git a/x11-misc/xbatt/xbatt-1.3_rc1.ebuild b/x11-misc/xbatt/xbatt-1.3_rc1.ebuild
new file mode 100644
index 000000000000..f1c2cc3b3bff
--- /dev/null
+++ b/x11-misc/xbatt/xbatt-1.3_rc1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit versionator eutils toolchain-funcs
+
+MY_PV=${PV/_rc/pr}
+DESCRIPTION="Notebook battery indicator for X"
+HOMEPAGE="http://www.clave.gr.jp/~eto/xbatt/"
+SRC_URI="http://www.clave.gr.jp/~eto/xbatt/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="xbatt"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXaw
+ x11-libs/libXext
+ x11-libs/libxkbfile
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-misc/imake"
+
+S="${WORKDIR}"/${PN}-$(get_version_component_range 1-2)
+
+src_prepare(){
+ epatch "${FILESDIR}"/${PN}-1.2.1-implicits.patch
+}
+
+src_compile() {
+ xmkmf || die
+ emake xbatt CDEBUGFLAGS="${CFLAGS}" CC="$(tc-getCC)" \
+ EXTRA_LDOPTIONS="${LDFLAGS}" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README* || die
+}